HELP! Generic Trust Failure with .NET Framework 4 install/update Win 7 RRS feed

  • Question

  • Hello

    I am running a Windows 7 box and recently I noticed that Windows Update keeps failing to update my .Net Framework.  I took it upon my self to trouble shoot this by removing .Net framework, which I couldn't because of the dreaded "Generic Trust Failure".  I then proceeded to use the .NET framework cleanup utility and then clean my %temp% folder as well as remove non 1999/2002 certificates from microsoft.  I then rebooted and tried to do a fresh install, but still receive the error.  I posted the specific details below. 


    I've looked through these forums and tried the many suggestions, but nothing so far has worked.  I am a web developer and because the .NET framework is not working, I am unable to use critical software such as Dreamweaver.  Any suggestions?


    [12/12/2010, 15:41:56] Verifying Digital Signatures: D:\36af95faa691e24d4fbbcc8da92485\SetupUtility.exe
    [12/12/2010, 15:41:56] Possible transient lock. WinVerifyTrust failed with error: 2148204800
    [12/12/2010, 15:41:56] Possible transient lock. WinVerifyTrust failed with error: 2148204800
    [12/12/2010, 15:41:56] D:\36af95faa691e24d4fbbcc8da92485\SetupUtility.exe - Signature verification for file SetupUtility.exe (D:\36af95faa691e24d4fbbcc8da92485\SetupUtility.exe) failed with error 0x800b0100 (No signature was present in the subject.)
    [12/12/2010, 15:41:56] D:\36af95faa691e24d4fbbcc8da92485\SetupUtility.exe Signature could not be verified for SetupUtility.exe
    [12/12/2010, 15:41:56] No FileHash provided. Cannot perform FileHash verification for SetupUtility.exe
    [12/12/2010, 15:41:56] File SetupUtility.exe (D:\36af95faa691e24d4fbbcc8da92485\SetupUtility.exe), failed authentication. (Error = -2146762496). It is recommended that you delete this file and retry setup again.
    [12/12/2010, 15:41:56] Failed to verify and authenticate the file -D:\36af95faa691e24d4fbbcc8da92485\SetupUtility.exe
    [12/12/2010, 15:41:56] Please delete the file, D:\36af95faa691e24d4fbbcc8da92485\SetupUtility.exe and run the package again
    [12/12/2010, 15:41:56] Action complete
    [12/12/2010, 15:41:56] calling PerformAction on an installing performer
    [12/12/2010, 15:41:56] Wait for Item (SetupUtility.exe) to be available
    [12/12/2010, 15:41:57] Final Result: Installation failed with error code: (0x800B010B), "Generic trust failure. " (Elapsed time: 0 00:00:14).

    Sunday, December 12, 2010 11:43 PM


All replies

  • Hi Harryj00
    Thank you for posting in MSDN Forum.
    According to your description of the problem, the issue you are experiencing is Windows Update keeps failing to update the .Net Framework. Base on the error log, this is caused by failed to verify and authenticate the file D:\36af95faa691e24d4fbbcc8da92485\SetupUtility.exe.
    You may follow the steps shown below to see if the issue is fixed.
    2.       Try to turn the .NET Framework feature off (Start button –> Control Panel –> Programs –> Turn Windows Features on or off –> clear check box next to Microsoft .NET Framework), and then turn it on.
    3.       Clean your %temp% folder, reboot the system.
    4.       Try to install .NET Framework again.
    5.       If you still cannot install .NET Framework, redo step 3, then download a standalone installer, and try to install it.
    If you still cannot install .NET Framework, you can use this Log Collection Utility to collect the installation logs, and sent the vslogs.cab file to me (v-anwu@microsoft.com).
    In addition, I’ve found follow links might be help:
    Hope this will help resolving your problem. If anything is unclear, please free feel to let me know.
    Best Regards,
    Andrew Wu

    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Larcolais Gong Wednesday, December 22, 2010 3:32 AM
    Thursday, December 16, 2010 7:44 AM
  • Hi Andrew.Wu

    The failure is also including; Microsoft Visual C++ 2010 x64 with the same error only there an other exe file than setuputility.
    Saw your link: http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/a228c9ca-a2a7-4db1-9bcd-37b98ef68bcf
    and tried everything that you wrote, but it didn't work. Same error. The exe file (setuputility) won't be deleted cause it is created each time u try to install.

    But I downloaded the Collect.exe and got a zip.file that i wanted to send you, but I believe the mail (v-anwu@microsoft.com) you wrote is wrong, because I keep getting delivery failure . Hope you can help me.
    Appriciate it!

    - Johannes

    Saturday, March 3, 2012 4:17 PM
  • Thankyou very much for ur help..that was really very helpful and i got what i wanted..thanks a lot.
    Wednesday, July 25, 2012 11:57 AM