locked
Unknown option '--no-version-vectors--no-version-vectors' RRS feed

  • Question

  • User123512 posted

    I have a Xamarin.Forms project that started to show the error Unknown option '--no-version-vectors--no-version-vectors' when trying to build the android app. Tried reinstall Xamarin and android SDK but the error still happen. Also tried to add <AndroidSdkBuildToolsVersion>20.0.0</AndroidSdkBuildToolsVersion> to the project file but nothing changes. Any hint on what is happening?

    Friday, April 29, 2016 10:30 PM

Answers

  • User2122 posted

    As far as I know, there are two possible causes.

    • The one that keeps happening to me is, after package updates updates, Xamarin studio adds, to the Android project file (.csproj), redundant <Import reference= ...> tags to one or more Xamarin packages. Deleting the redundant <Import reference=...> tags fixes the problem every time.

    • I've seen mention of needed to have Android SDK Build-Tools version 23.0.0 or higher installed and not having any Android SDK Build-Tools lower than version 23.0.0 installed. I don't know how important this is because I've never encountered it.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, September 2, 2016 3:59 PM

All replies

  • User189679 posted

    did you ever find a solution for this?

    Saturday, June 4, 2016 11:39 PM
  • User123512 posted

    Sadly, no. I ended up reinstalling windows because of another problems and the error have not occur anymore since then.

    Sunday, June 5, 2016 4:10 AM
  • User148199 posted

    I'm facing the same issue. Has anyone have a solution for this?

    Wednesday, July 27, 2016 7:48 AM
  • User30174 posted

    Same here, it's doing my head in :neutral:

    AAPT : error : Unknown option '--no-version-vectors--no-version-vectors'

    Monday, August 1, 2016 12:33 PM
  • User2122 posted

    As far as I know, there are two possible causes.

    • The one that keeps happening to me is, after package updates updates, Xamarin studio adds, to the Android project file (.csproj), redundant <Import reference= ...> tags to one or more Xamarin packages. Deleting the redundant <Import reference=...> tags fixes the problem every time.

    • I've seen mention of needed to have Android SDK Build-Tools version 23.0.0 or higher installed and not having any Android SDK Build-Tools lower than version 23.0.0 installed. I don't know how important this is because I've never encountered it.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Friday, September 2, 2016 3:59 PM
  • User227932 posted

    I got around this problem thanks to @BuildCalc comment - it appears that the vector project is imported twice in the .csproj file, removing one of these makes the build work again.

    Thursday, September 22, 2016 5:16 AM
  • User49399 posted

    +1 for what AidanMorgan said

    I am highly frustrated with package updating & referencing in Android projects. I spent a total of around 10 hours this weekend sorting it out - for one project - and there's still more sorting to do.

    Monday, December 5, 2016 8:23 AM
  • User270787 posted

    Indeed, a lot of developpers are frustrated with this "awasome" Platform :-)

    Wednesday, January 18, 2017 12:27 PM
  • User166943 posted

    i'm more than frustrated, i'm pist off

    Thursday, March 2, 2017 9:50 AM
  • User191 posted

    @AidanMorgan said: I got around this problem thanks to @BuildCalc comment - it appears that the vector project is imported twice in the .csproj file, removing one of these makes the build work again.

    Yeah, you've save me from this crazy nut error message.

    Monday, May 22, 2017 2:36 PM