locked
Installing visual studio 2010 - error RRS feed

  • Question

  • Hi,

    So I was installing VS2010 Ultimate from a dvd and I left the install running and went to play on my xbox. When I returned (within a half hour or so), the laptop had gone into the sleep mode (because of the inactivity). On waking it up, I saw that the vs2010 installation was still stuck and not really moving. So I cancelled the installation.

     

    Now I am trying to run it again, but I keep running into some error or the other. Is there a way to cleanup any registry entries or folders or whatever is needed to run the installation successfully. There is nothing wrong with the dvd for sure, because i have used in  other laptops and it has installed perfectly.

    thanks in advance,

    S

    Thursday, September 15, 2011 6:15 AM

Answers

  • From the new logs I found that the vs_setup.msi “is invalid”.

     

                    > “[09/17/11,12:10:08] Microsoft Visual Studio 2010 Ultimate - ENU: ***ERRORLOG EVENT*** : ERROR_INSTALL_PACKAGE_INVALID returned in CRootComponent::Install; the following file is invalid: f:\vs_setup.msi

     

    Have you already tried to install VS with the antivirus disabled?

    If yes this issue is probably caused by the VS’s installer. Try to download again the ISO about VS.


    || Michele Brina || Developer Support Engineer || http://blogs.msdn.com/itasupport
    • Proposed as answer by Michele Brina Tuesday, September 20, 2011 2:42 PM
    • Marked as answer by r_a_ven Tuesday, September 20, 2011 7:47 PM
    Tuesday, September 20, 2011 2:42 PM

All replies

  • Hi raven,

    in order to start the troubleshooting please follow these steps:

    1. download http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=12493

    2.       Click on the Start menu, choose Run, type msconfig and click OK

    3.       In the System Configuration tool, click on the Services tab

    4.       Check the box labeled Hide all Microsoft services

    5.        Click the Disable All button to disable all non-Microsoft services

    6.       In the System Configuration tool, click on the General tab

    7.       Click the Selective startup radio button

    8.       Uncheck the box labeled Load startup items

    9.       Click OK to accept all changes in the System Configuration tool

    10.   Reboot for the changes to take effect

    11.   Delete all files in %temp%

    12.   Start VS2010 installation

    13.   Take a screenshot about the issue

    14. run Collect.exe

    15. you can analize these log file created in %temp% or you can send me by using this email: a-mibrin@microsoft.com

    Note: please attach the link of this post in the mail.

     


    || Michele Brina || Developer Support Engineer || http://blogs.msdn.com/itasupport
    Thursday, September 15, 2011 7:26 AM
  • Hi - please check your email.

    There is a zip file attached ni my email - so its possible that my email lands in your spam folder.

     

    thanks

    S

    Friday, September 16, 2011 2:54 AM
  • Hi Sunil,

    I quickly troubleshooted your log files and I found these useful information:

    Source:MsiInstaller  Id:10005 (0x00002715)  Time:2010.05.15 21:57:56  Type:ERROR
    Strings (7):[Product: Windows Live Mail -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2762. The arguments are: , , ] [(NULL)] [(NULL)] [(NULL)] [(NULL)] [(NULL)] []
    00000000 | 7b363343 31313039 452d4439 37372d34 3945442d 42434533 2d443030 44304246 | {63C1109E-D977-49ED-BCE3-D00D0BF
    00000020 | 31383744 367d | 187D6}

     

    Source:MsiInstaller  Id:10005 (0x00002715)  Time:2010.05.16 12:43:35  Type:ERROR
    Strings (7):[Product: Windows Live Communications Platform -- The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2762. The arguments are: , , ] [(NULL)] [(NULL)] [(NULL)] [(NULL)] [(NULL)] []
    00000000 | 7b334234 45363336 452d3944 36352d34 4436372d 42413631 2d313839 38303038 | {3B4E636E-9D65-4D67-BA61-1898008
    00000020 | 32334635 327d | 23F52}                                               

    It seems that the installation of VS fails because there are these two component (application??) that fails during the installation.

    In order to fix your issue, try to install manually these products and, after that, install VS.

    Let me know :)


    || Michele Brina || Developer Support Engineer || http://blogs.msdn.com/itasupport
    Friday, September 16, 2011 7:16 AM
  • Hi Michele. I sent you another email with the attachments.

    There was some progress and now its always erroring out at the same location :)

     

    Thanks,

    Sunil

    Saturday, September 17, 2011 5:52 PM
  • From the new logs I found that the vs_setup.msi “is invalid”.

     

                    > “[09/17/11,12:10:08] Microsoft Visual Studio 2010 Ultimate - ENU: ***ERRORLOG EVENT*** : ERROR_INSTALL_PACKAGE_INVALID returned in CRootComponent::Install; the following file is invalid: f:\vs_setup.msi

     

    Have you already tried to install VS with the antivirus disabled?

    If yes this issue is probably caused by the VS’s installer. Try to download again the ISO about VS.


    || Michele Brina || Developer Support Engineer || http://blogs.msdn.com/itasupport
    • Proposed as answer by Michele Brina Tuesday, September 20, 2011 2:42 PM
    • Marked as answer by r_a_ven Tuesday, September 20, 2011 7:47 PM
    Tuesday, September 20, 2011 2:42 PM