none
blue double arrow on shortcut icon under Windows 10

    Question

  • Hello,

    After a recent update of Windows 10 pro, when i install my softwares with my installers (made as a VS setup project), a double blue Arrow is overlayed on the icon of the desktop shortcuts of my program.

    Some one can explain why, and especially how to remove these blue arrows?

    best regards

    Pascal

    Thursday, December 29, 2016 2:59 PM

All replies

  • Hi!

    Here is the link in order to remove the shortcut arrow on Windows 10 : http://winaero.com/blog/remove-shortcut-arrow-overlay-in-windows-10/

    Hope it wil be useful.

    If it's good for you, can you mark this answer as answer of your question please?

    Follow me on twitter : https://twitter.com/NordineMhoumadi


    Please remember to close your threads by marking helpful posts as answer and then start a new thread if you have a new question. Please don't ask several questions in the same thread. SVP utiliser le Marquer comme reponse; sur les reponses qui vous aide car cela permet aux personnes qui peuvent rencontrer le meme probleme que vous, de retrouver rapidement quelle est la reponse qui a resolu leur probleme. De plus, cela encourage aussi la personne qui a repondu a votre question, et de repondre aux suivantes...

    Thursday, December 29, 2016 3:14 PM
  • Hi Nordine,

    thanks for reply, but this is not the Arrow from which i spoke.

    Below is this annoying double blue Arrow:

    best regards

    Thursday, December 29, 2016 4:33 PM
  • I think that it is an indicator of compressed files and folders. To verify this, right-click the icon, go to General, Advanced, then see the “Compress contents to save disk space” checkbox. Since it is rarely used in case of desktop links, the effect will be not observed immediately; probably you will have to restart the machine if you change the value.

    Thursday, December 29, 2016 5:59 PM
  • Thanks for the support from Nordine MHOUMADI and Viorel_.

    Hi Pascal,

    Welcome to the MSDN forum.

    Refer to your description, I agree with Viorel_’s solution. To check the option ‘Compress contents to save disk space’ and apply it, then check this icon again.

    Meanwhile, some other methods that I found as below:

    1. Remake the shortcuts from the .exe files, delete the old shortcuts and the icon should as usual.

    2. If you create the setup installer using the InstallShield, please edit the shortcuts "Behavior" from "advertised=YES" to "advertised=NO".

    3. Do you have Norton 360 or some other Norton security suites? The double blue icons mean there are files that haven't been backed up. It can be turned off. You can have a look at this similar issue: Blue Double Arrows and some other workarounds are also mentioned in here.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 30, 2016 7:31 AM
    Moderator
  • Hi,

    thank for your replies.

    Exact, this is what the icon suggests, but this is false; it's just a shortcut to an .exe (in fact a .net assembly).

    I verified that the option  ‘Compress contents to save disk space’  is not checked.

    My setup installer is done with a Visual Studio Installer project.

    I don't have Norton tools.

    And of course, if i create a new shorcut manually, that's ok, but i can not tell to my customers to do the same!

    The problem has appeared only after a recent update of Windows 10!

    well well well, i will stop for this year.

    And i wish you all a happy new year

    Friday, December 30, 2016 7:16 PM
  • Hi Pascal,

    Happy new year and thank you for your update.

    >>The problem has appeared only after a recent update of Windows 10!

    Could you please try to remove the recent updates from windows update to find which one affect this issue, it will help us to research this issue, thank you for your support.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, January 02, 2017 8:35 AM
    Moderator
  • Hi Sara,

    Happy new year too.

    I can not remove recent update because:

    - i need recent update which is required by my recent graphic card,

    - and, any way, how to do this, W10 do updates automatically.

    My version of W10 is the 1607 (os version 14393.576).

    I tried to change options of the installer project (package file ,compression), using icon file or the icon of the output project,...   i always obtain the same result. On the other hand, i made a little app (just one empty form) and an installer for this app, and this works (no double Arrow on the icon of the desktop shortcut). Does the problem related to the size of the installer?

    best regards

    Pascal

    Tuesday, January 03, 2017 7:08 PM
  • Hi Pascal,

    >>- and, any way, how to do this, W10 do updates automatically.

    To check if the specific windows update affects this issue, you can go to Installed Updates like the following and right click it to uninstall one by one. If it is be found, you can also install it back again.

    Best regards,

    Sara

     


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, January 04, 2017 9:04 AM
    Moderator
  • Hi Sara,

    In fact, i think (but i'm not sure), that i have this behavior since the installation of the version 1607 (i installed it in the end of october). But i don't want to uninstall it (i need it to be able to use my new graphic card).

    Other idea?

    best regards

    Wednesday, January 04, 2017 2:26 PM
  • Hi again,

    i found the origin of the problem.

    In fact, this double Arrow appears when the installer do the install for 'Everyone', wether this option is selected by default or manually. If the option 'Just me' is selected no double Arrow. Funny, no?

    Someone has a solution or a workaround (other than set the option 'Just me' by default)?

    best regards

    Pascal

    • Proposed as answer by hasyed Wednesday, June 21, 2017 2:57 PM
    Wednesday, January 04, 2017 6:56 PM
  • Hi Pascal,

    I tried to create an installer (not empty form) on the same windows 10 version 1607, the shortcut icon has no issue no matter the option is set to ‘Everyone’ or ‘Just me’.

    >> Does the problem related to the size of the installer?

    Please have a try with a new app not very little, then create the shortcut to check this issue again, it can help us to excludes the possibility of the size. Or create a new Visual Studio Installer project and copy your current project into it, then check it again.

    In case, your installer project be corrupted, please have a test with the following: (backup your solution)

    1. Delete the .suo or .vs file under your solution folder, the .vs folder might be hidden.

    2. Restart the computer, clean %temp% folder, clean the solution in VS and recreate the installer or shortcut

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, January 05, 2017 6:36 AM
    Moderator
  • Hi Sara,

    I already do what you suggest. I have this behavior with:

    - a totaly new  app (with 1 elementary form)

    - several of my softwares, with old installer project and also new installer project

    I can give you a link where to download my new small app (1 form), if you want.

    best regards

    Pascal

    Thursday, January 05, 2017 10:38 AM
  • Hi Pascal,

    You can share your new small app with this issue, then we check it on our side.

    BTW, the icon issue affects the usage your installer shortcut? Does the shortcut with double blue arrow can work fine as before?

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 06, 2017 6:08 AM
    Moderator
  • Hi Sara,

    please find this link where to download a little VS2015CE solution.

    Except the appearence, the shortcuts works normally. Perhaps (probably), it's a problem with my Windows and not a problem of the installer!

    best regards

    Pascal

    Friday, January 06, 2017 10:16 AM
  • I'm not sure whether the following information will be of any use, but I'm experiencing similar behavior with shortcuts as described by Pascal above:

    My development environment is as follows: Microsoft Visual Studio Community 2015 (Version 14.0.25431.01 Update 3) running on Windows 7 Home Premium (Version 6.1.7601 Service Pack 1 Build 7601).

    My setup project consists of an Visual Basic application of approx. 60 forms with an application shortcut to be deployed to the user's desktop (setting = "For everyone").

    When installing this setup on a separate laptop running Windows 10 Pro (Version 1511, OS Build 10586.713), the resultant application shortcut on the desktop shows double blue arrows, with no compression attributes set. 

    The shortcut functions correctly, but looks confusing to my users.

    Regards

    Sylvia

    Friday, January 06, 2017 2:17 PM
  • Hi Pascal,

    >>Perhaps (probably), it's a problem with my Windows and not a problem of the installer!

    To confirm this, please copy your installer project to another computer and have a test.

    If it is be proved, it is better to redirect to this forum:https://answers.microsoft.com/en-us/windows/forum/windows_10 for more information, you will get a more professional support, since our forum is to discuss Visual Studio WPF/SL Designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System, and Visual Studio Editor, thank you for your understanding.

    If this issue only related to the installer project, please navigate to the VS installer support forum: https://social.msdn.microsoft.com/Forums/windows/en-US/home?forum=winformssetup for a better support.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, January 09, 2017 9:17 AM
    Moderator
  • Hi Sylvia,

    Welcome to the MSDN forum.

    Since our forum is to discuss Visual Studio WPF/SL Designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System, and Visual Studio Editor, your issue is more related to the development of VS installer, if you also use the VS installer to create this installer, please redirect to this appropriate forum:https://social.msdn.microsoft.com/Forums/windows/en-US/home?forum=winformssetup for a better support, thank you for your understanding.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, January 09, 2017 9:20 AM
    Moderator
  • Hello Sara,

    Presently, i do not have the possibility to test on another W10 machine.

    Have you try to install my little app on your side?

    best regards

    Pascal

    Tuesday, January 10, 2017 7:13 PM
  • Hi Pascal,

    Thank you for your reminder.

    Since your issue is more related to the VS installer development and our forum is to discuss the VS IDE Editor, I recommend you redirect to this suitable forum: https://social.msdn.microsoft.com/Forums/windows/en-US/home?forum=winformssetup and open a new thread for your issue with your example installer project and they will provide a more professional support for your issue, sorry for this inconvenience and thank you very much for your understanding.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, January 11, 2017 7:44 AM
    Moderator
  • That worked for me. Thanks.

    hs

    Wednesday, June 21, 2017 2:57 PM
  • which one is worked ?
    Thursday, June 22, 2017 6:48 AM
  • hi 

    i would like wath is the solution for this case that work.

    i'm using VS 2008 and my setup projects with shortcuts in windows 10 at x64 all shortcuts have the two blue arrows. 

    So if please can give me the solution that work???

    Best regards

    Tuesday, March 06, 2018 4:56 PM