locked
fail to deploy windows container application to service fabric local cluster, help me , thanks RRS feed

  • Question

  •  when I  deploy a windows container application to service fabric local cluster, the  service fabric explorer page shows error like :

    Error event: SourceId='System.Hosting', Property='Download:1.0:1.0:4bf90ecf-249b-4eef-9919-da5f8365b764'.

    There was an error during download.

    anyone knows the solution? thanks

    and , when I pull the same image manully with 'docker pull',  the result is also fail,  and error is below:

    failed to register layer: re-exec error: exit status 1: output: ProcessUtilityVMImage \\?\C:\ProgramData\Docker\windowsfilter\91bae7294040a53461d7444471cdc47bbf412fe259c0c819503822290331e531\UtilityVM: The system cannot find the path specified 

    and when I push image to the container registry , the power shell shows :

    e7e90b98dfb7: Skipped foreign layer

    67903cf26ef4: Skipped foreign layer

    • Edited by pan_happy Wednesday, January 9, 2019 7:47 AM
    Wednesday, January 9, 2019 7:08 AM

Answers

All replies

  • Hi pan_happy,

    Please share the documentation if you are following one.

    Also make sure you have the correct image name and tag.

    If possible share the image name and tag also.

    Wednesday, January 9, 2019 7:32 AM
    Owner
  • hi ,friend . I do not have documentation .  

    image name is hello-world

    tag is conreg3.azurecr.io/hello-world

    thanks

    Wednesday, January 9, 2019 7:40 AM
  • Hi,

    Is this the image you are using?

    Also checkout this document for creating and deploying a container based service fabric app in Azure.

    Though this document refers to deployment in Azure, You can build locally and check.

    Try this out and let me know.

    I hope your local service fabric cluster is windows based. So you need to switch your docker to windows containers.
    Wednesday, January 9, 2019 9:18 AM
    Owner
  • thank u so much ! my dear friend ,  your suggestion helps me a lot!
    Thursday, January 10, 2019 7:23 AM
  • HI,

    You can also post which steps solved your problem. That will help other users.

    Thursday, January 10, 2019 7:25 AM
    Owner