none
Getting erro "An error has occurred: 0x80004005 Unspecified error" while registering .Net 2.0 RRS feed

  • Question

  • By mistake I uninslalled .Net Framework 2.0 from control panel "Uninstall programs" option. Then I Insalled VS 2005 in my laptop for my project requirement. while I try to register ASP.NET 2.0 from VS 2005 command prompt "aspnet_regiis /i" , I am getting error "An error has occurred: 0x80004005 Unspecified error".

    I couldn't see framework 2.0 in control panel "Turn Windows features ON/OFF" though I see Framework 3.5.

    OS installed : Windows 7 enterprise 32 bit version

    Please help me to register framework 2.0  "aspnet_regiis /i"


    • Edited by MuhilanKP Friday, June 7, 2013 11:25 PM Added OS details
    Friday, June 7, 2013 11:05 PM

Answers

All replies

  • Windows 7 comes with .NET Framework 3.5.1 embedded as part of the OS

    3.5.1 is .NET Framework 2.0, 3.0 and 3.5, plus patches through 3.5 SP1.

    Because 3.5.1 is a Windows Feature, it cannot be removed or installed by the user. Therefore, when you say "By mistake I uninslalled .Net Framework 2.0 from control panel "Uninstall programs" option", that is not possible.

    So, please clarify what you actually uninstalled.

    You can verify the .NET Frameworks on your system with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 2.0 selected, then post the FIRST 15 lines AND the LAST 15 lines of the tool log here.

    Saturday, June 8, 2013 1:32 PM
  • Pasted .NET framework verification tool logs as requested. Please guide me to resolve the issue. Appreciate the quick help.

    First 15 Lines from Logs:

    [06/08/13,16:26:56] Beginning of new SetupVerifier activity logging session
    [06/08/13,16:26:56] Activity log file location: C:\Users\CWR~1.MPA\AppData\Local\Temp\setupverifier_main_06-08-13_16.26.56.txt
    [06/08/13,16:26:56] Error log file location: C:\Users\CWR~1.MPA\AppData\Local\Temp\setupverifier_errors_06-08-13_16.26.56.txt
    [06/08/13,16:26:56] Build created on September 10, 2012
    [06/08/13,16:26:56] Detected operating system: Windows 7 (x86)
    [06/08/13,16:26:56] For more information about repairing the .NET Framework, see [06/08/13,16:26:56] Install state for .NET Framework 1.0: not installed.
    [06/08/13,16:26:56] Install state for .NET Framework 1.1: not installed.
    [06/08/13,16:26:56] Install state for .NET Framework 2.0: installed with service pack 2.
    [06/08/13,16:26:56] Install state for .NET Framework 3.0: installed with service pack 2.
    [06/08/13,16:26:56] Install state for .NET Framework 3.5: installed with service pack 1.
    [06/08/13,16:26:56] Install state for .NET Framework 4 Client: not installed.
    [06/08/13,16:26:56] Install state for .NET Framework 4 Full: not installed.
    [06/08/13,16:26:56] Install state for .NET Framework 4.5: not installed.

    Last 31 Lines from Logs:

    [06/08/13,16:27:01] Section [Registry - .NET Framework 2.0 (Common)] - stop parsing entries
    [06/08/13,16:27:01] Section [Registry - .NET Framework 2.0 (32-bit)] - start parsing entries
    [06/08/13,16:27:01] Key: HKLM\SOFTWARE\Microsoft\.NETFramework
     Value: InstallRoot
     Expected Data: c:\windows\microsoft.net\framework\
     Actual Data: c:\windows\microsoft.net\framework\
    [06/08/13,16:27:01] Section [Registry - .NET Framework 2.0 (32-bit)] - stop parsing entries
    [06/08/13,16:27:01] Not running action 'Registry - .NET Framework 2.0 (64-bit)' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [06/08/13,16:27:01] Not running action 'Registry - .NET Framework 2.0 (Wow6432Node)' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [06/08/13,16:27:01] Section [Registry GE - .NET Framework 2.0 SP2 (Common)] - start parsing entries
    [06/08/13,16:27:01] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727
     Value: SP
     Expected Data: 2
     Actual Data: 2
    [06/08/13,16:27:01] Section [Registry GE - .NET Framework 2.0 SP2 (Common)] - stop parsing entries
    [06/08/13,16:27:01] Section [Registry GE - .NET Framework 2.0 SP2 (32-bit)] - start parsing entries
    [06/08/13,16:27:01] Section [Registry GE - .NET Framework 2.0 SP2 (32-bit)] - stop parsing entries
    [06/08/13,16:27:01] Not running action 'Registry GE - .NET Framework 2.0 SP2 (64-bit)' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [06/08/13,16:27:01] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [06/08/13,16:27:01] ExecutablePath = 'Netfx20TestApplication.exe'
    [06/08/13,16:27:01] FriendlyName = '.NET Framework 2.0 test application'
    [06/08/13,16:27:01] TimeoutSeconds = '300'
    [06/08/13,16:27:01] WaitOnExit = 'true'
    [06/08/13,16:27:01] Silent = 'true'
    [06/08/13,16:27:01] Launching process 'Netfx20TestApplication.exe' now
    [06/08/13,16:27:01] Process successfully launched. Waiting 300 seconds for it to complete.
    [06/08/13,16:27:02] Process 'Netfx20TestApplication.exe' exited with return code 0
    [06/08/13,16:27:02] Section [Files - .NET Framework netfxperf.dll] - start parsing entries
    [06/08/13,16:27:02] File C:\Windows\system32\netfxperf.dll (version 4.0.40305.0) is installed on the system
    [06/08/13,16:27:02] Section [Files - .NET Framework netfxperf.dll] - stop parsing entries
    [06/08/13,16:27:02] Verification succeeded for product .NET Framework 2.0 SP2

    Saturday, June 8, 2013 9:37 PM
  • The verification log shows that your .NET Framework is installed and configured correctly.

    As you problem with "I try to register ASP.NET 2.0 from VS 2005 command prompt "aspnet_regiis /i"

    is not being caused by the .NET Framework, I suggest you ask the ASP.NET experts here:

    http://forums.asp.net/17.aspx/1?Installation+and+Setup

    Sunday, June 9, 2013 5:12 PM
  • Thanks much. I posted the problem in the above site as you suggested.
    Sunday, June 9, 2013 6:41 PM
  • ASP.NET expert suggested to follow the steps provided in the URL:

    http://www-01.ibm.com/support/docview.wss?uid=swg21584455

    Able to execute aspnet_regiis /i command succesfully

    Thanks

    • Marked as answer by MuhilanKP Thursday, June 13, 2013 3:20 PM
    Thursday, June 13, 2013 3:20 PM