locked
Opengl32.lib linking problem RRS feed

  • Question

  •  

    Hi there!!

     

    I'm working in a openGL project for university and I'm using VS2008 in windows vista.

     

    Building the project it tells me that it couldn't open the input file 'opengl32.lib' with a linking critical error (error 1181).

     

    I've triple checked and the library is with all the libraries of VS, in the SDK directory.

     

    Can anyone give me some clue to resolve this problem?

     

    I have all the others openGL libraries installes too, and I don't have any problems with them

     

     

    Maika

    Monday, January 7, 2008 3:06 PM

Answers

  • Check if your SDK's lib folder path is added in Visual C++ lib directories.  Tools ->Options ->Project & Solutions ->VC++ Directories in Visual C++ 2005. In VC++ 6 it is located on Directories Tab in Tools ->Options.
    Thursday, January 10, 2008 12:28 PM

All replies

  • Should I post this in the Visual Studio 200b forum too? It seems that here nobody can help me
    Wednesday, January 9, 2008 8:31 PM
  • Hi~

    This forum about Visual C++ general, not Visual studio 2008.

    I'm sorry but, You'd better move this post to Visual Studio C++ 2008 Forum.

    Bye~

     

    Thursday, January 10, 2008 4:06 AM
  • Ok, thanks
    Thursday, January 10, 2008 12:14 PM
  • Check if your SDK's lib folder path is added in Visual C++ lib directories.  Tools ->Options ->Project & Solutions ->VC++ Directories in Visual C++ 2005. In VC++ 6 it is located on Directories Tab in Tools ->Options.
    Thursday, January 10, 2008 12:28 PM
  • And how I edit that?... I have 2 lines in the executable option that have the SDK, but they're variables, like this

    $(WindowsSdkDir)\bin and $(FrameworkSDKDir)bin

    I just overwrite those lines? Where I can see the value of those variables?


    Maika

    P.S: This is the error I got: LINK : fatal error LNK1181: cannot open input file 'opengl32.lib',
    Sunday, January 13, 2008 10:16 PM
  • Check if your SDK's lib folder path is added in Visual C++ lib directories.  Tools ->Options ->Project & Solutions ->VC++ Directories in Visual C++ 2005. In VC++ 6 it is located on Directories Tab in Tools ->Options.

    This error occurred for me based on a mistake I made while "linking" the project to the GLUT libraries.  I had a comma separating the libraries, when there should only be a space (of course, how silly of me, Microsoft).  Using Visual C++ 7.

    Right-click yourSolutionName --> Properties --> Linker (on the left) --> Input --> "Additional dependencies"

    I have the following libraries: "opengl32.lib glu32.lib glaux.lib glut32.lib".  Make sure that you do not have commas here, or quotation marks for that matter.

    I made this mistake by copying and pasting a little too literally from this setup resource for openGL:
    Wednesday, April 1, 2009 1:22 AM
  • I was having the same trouble and was directed to this thread. The reason I was getting the error was I had a new machine which did not have the latest SDKs installed(the old ones might still show the library files in the folder, but that doesn't work). Those who are getting the same errors might want to download the latest SDK's from Microsoft's website. Hope that helps.
    Tuesday, September 13, 2011 3:53 PM