none
ASR setup question RRS feed

  • Question

  • HI all, looking for some help to a question I have. 

    I have used ASR for some time now with On-Prem (VMWare) to Azure. I am now setting up a lab for Azure to Azure. If I deploy the Vault in the 2nd region I can then go ahead and choose VM to replicate from primary region and all works just swell. But, what if I want to isolate the Vault because I don't want servers popping up with the same names and IPs. If I isolate the Vault VNet then my replication fails, I guess cos it cannot see the vault because the VNet is isolated. But if I setup global vnet peering, this will expose the vaults VNet and cause issues if VMs are online at the same time.

    I'm missing something here - any help on this one. 

    PS. I have read a ton on this but can't seem to find a logical answer. If someone can explain that would be very helpful.

    P

    Thursday, March 14, 2019 11:52 AM

All replies

  • Can you explain what you mean by isolate technically?

    Joe

    Thursday, March 14, 2019 3:27 PM
  • Hi, so if I intend to test failover I would need to ensure the VNet with the replicated VMs is isolated from production?
    Thursday, March 14, 2019 3:47 PM
  • Yes, especially if they are domain joined VMs. I normally create a specific test vnet for test failovers. I either give the VMs temporary public IPs secured by NSG for a once off test, or if testing multiple VMs over a period of time, add a vnet gateway and use P2S VPN to connect to into vnet then RDP to private IP of VM with a local admin account and test anything required.

    Joe

    Friday, March 15, 2019 10:12 AM
  • Either you can add Public to one of the VM and connect to rest of the VMs using the private IP instead of giving public IP's to all VMs.
    Friday, March 15, 2019 1:48 PM