locked
Where is Web site administrative tool to set form based security in VS 2013 on Windows 7 RRS feed

  • Question

  • User-1312127319 posted

    I have version 4.5.50938 .NET framework and version 12.0.30324.00 Update 2 RC Visual Studio 2013

    I googled and I got a hint that maybe this is deprecated.  I know forms-based web sites are older now but I need to use this model to do some maintenance work.  What would I use instead to set up for my web forms?  Is there any way I can still use WAT from the commanmd line or something?  Thanks.

    Wednesday, May 21, 2014 12:37 PM

Answers

  • User-166373564 posted

    Hi pharmkittie,

    Does anyone know what could caiuse the WAT site to come up but to immediately timeout?

    For this timeout issue, you could close  browser completely, stop the development server, and restart Admin tool again.

    In addition, it's also recommended to refer to the msdn article below to check your congiguration in Web site administrative tool.

    # Web Site Administration Tool Overview

    http://msdn.microsoft.com/en-us/library/vstudio/yy40ytx0(v=vs.100).aspx 

    If you still has any concern, please give your response.

    Regards

    Angie 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 26, 2014 11:35 PM

All replies

  • User-1312127319 posted

    I used this link to attempt to get to it via the command line: http://blogs.msdn.com/b/webdev/archive/2013/08/19/asp-net-web-configuration-tool-missing-in-visual-studio-2013.aspx

    Worked great for me but then when I attempted to reach the WAT (web site admin tool) via the site I see this: 

    Anyone know what I shoild do next?  Thanks.wat tool comes up but with error

    Wednesday, May 21, 2014 1:04 PM
  • User281315223 posted

    In Visual Studio 2012

    If you were referring to the ASP.NET Configuration area (which used to be located within the Solutions Explorer in Visual Studio 2010) to manage members, roles and other authentication and authorization information, it has been moved.

    You'll find that in Visual Studio 2012 it has been moved under the Project Menu and can be accessed through the following steps : 

    1. Click on your Project within the Solutions Explorer.
    2. Select Project from the menu within Visual Studio 2012.
    3. Choose the ASP.NET Configuration option at the very bottom.

    In Visual Studio 2013

    In Visual Studio 2013, it is quite a bit more elusive and harder to find and you have to use the Visual Studio Command prompt to access it as per these instructions :

    clip_image002

    Have you tried cleaning and rebuilding your application since running the necessary Command Line tool? You might also try to ensure that you are running Visual Studio as an Administrator (Right-click > Run as Administrator) to see if that helps at all.

    The issue may be related to the different framework versions from your original application to the one being used within Visual Studio 2013. Have you tried running this in an older version of Visual Studio (possibly the one that it was built in) to see if it works through there?

    Wednesday, May 21, 2014 1:11 PM
  • User-1312127319 posted

    Thanks Rion Williams.  I'm sorry that I wasn't clear about what I meant by maintenance.  I am doing new development but I am not a .NET developer.  I need to do an application as quickly as I can but I am used to using the version from years ago (.NET 2.0) with web forms.  I have to use VS 2013 but I want to use the old web forms and WAT to set up forms-based security.  THis is just a quick app for inside our area to help us track some things.  

    THe URL I'm using to access the tool is : http://localhost:8082/asp.netwebadminfiles/default.aspx?application%20Physical%20Path=C:\Users\someoneWho\Documents\Visual%20Studio%202013\WebSites\WebSiteWISE%20&applicationUrl=/

    I do access the WAT but it times out immediately.  Thanks again.

    Wednesday, May 21, 2014 1:50 PM
  • User-1312127319 posted

    Does anyone know what could caiuse the WAT site to come up but to immediately timeout?  At this point I'm just trying to get to the site.  Should I start a new post that focuses on this specific problem?  Thanks.

    Thursday, May 22, 2014 10:21 AM
  • User-166373564 posted

    Hi pharmkittie,

    Does anyone know what could caiuse the WAT site to come up but to immediately timeout?

    For this timeout issue, you could close  browser completely, stop the development server, and restart Admin tool again.

    In addition, it's also recommended to refer to the msdn article below to check your congiguration in Web site administrative tool.

    # Web Site Administration Tool Overview

    http://msdn.microsoft.com/en-us/library/vstudio/yy40ytx0(v=vs.100).aspx 

    If you still has any concern, please give your response.

    Regards

    Angie 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 26, 2014 11:35 PM