none
Digital Signer in Driver Properties doesn't display MS signed after update WHQL signed driver on Windows 2012 & Windows 8. RRS feed

  • Question

  • My driver submission for Windows 2012 & Windows 8 has passed review and I got the signed CAT files back from Microsoft.  I incorporated the signed CAT files to my driver packages and did the fresh installation of Windows 2012 & Windows 8 x64/x86 and the "Digital Signer" shows correctly in the Driver Properties as "Microsoft Windows Hardware Compatibility Publisher" after installation.

    However, when I used the same WHQL signed driver package to update the driver on my Windows 2012 & Window 8 x64/x86 test systems that already have the original company signed driver installed, the "Digital Signer" in the Driver Properties has no change after updated. It still shows company signed in "Digital Signer"

    under Driver Properties and Driver Details.

    Do you have any idea why the WHQL signed CAT file doesn’t work for driver update in Windows 2012 & Windows 8 x64/x86?  

    I have asked Microsoft Windows Sysdev Dashboard <sysdev@microsoft.com>.  They suggested I work with WDK team.

    Please let me know if I need to open a support case to discuss this issue.

    Thanks

    Friday, November 2, 2012 1:03 AM

All replies

  • What does the %windir%\inf\setupapi.dev.log file say about your attempt to update the driver?  Does it say that it tried to import the driver but it already exists?
    Friday, November 2, 2012 4:31 PM
  • What exactly message should I look for in %windir%\inf\setupapi.dev.log?

    There is a message in %windir%\inf\setupapi.dev.log as follow:

         sto:           Driver package already imported as 'oem1.inf'.

    Friday, November 2, 2012 6:51 PM
  • It sounds like what I suspected might be going on.  When importing a driver, it is given a unique identity.  Changing the signature does not alter this identity.  When you try to update the device to be the driver package with the new signature, it sees that a driver with the same identity already exists and doesn't import the driver.  The new signature is not getting on to the system.  You have to remove the driver package with the old signature from the system if you want the driver package with the new signature to be added.
    Friday, November 2, 2012 8:53 PM
  • Do you mean I have to uninstall the driver with the old signature first then install the new WHQL signed driver package on Windows 2012/Windows 8?

    I can't uninstall or remove the driver since it requires a reboot and my OS is booted from the controller.

    For others old Windows versions (Windows 2008/Windows 7), update driver directly from company signed to WHQL signed has no problem.

    Friday, November 2, 2012 10:18 PM
  • Yes, that is what I mean.  Why do you need to get your WHQL signed driver package to install on top of the driver package with the old signature?  Don't your customers only get the WHQL signed driver package?

    When you say this worked on Windows 7, was the INF exactly the same between the old and new driver?  If it wasn't, then it should work.  However, my understanding is that in your current situation, the INFs are exactly the same and only the signature is different.

    Monday, November 5, 2012 7:47 PM
  • We normally release the driver package with the old signature, then post the WHQL signed driver package on company website later for customer to update since it takes time to run through the tests for all the supported OS.  In this case, our concern is that if some customers have installed Windows 8 OS with the old signature driver package then update with the WHQL signed driver package, they may have question why the WHQL signed driver package is still NOT WHQL certified.

    We have different driver package for Windows 7.  I certified Windows 7 driver package using 'WLK' instead of 'HCK' and the WHQL signature shows correctly after update with the WHQL signed driver package on Windows 7.

    For either Windows 7 or Windows 8, the INF file is exactly the same between the old and the new driver package.  I only replace the .CAT file on corresponding driver package and keep everything else untouch.

    Tuesday, November 6, 2012 8:38 PM
  • The same happens to me but when trying to change the retail drive for the checked driver, even if is to switch from a digitall signature (third party) to another digitall signature or from digitall signature to WHQL (yes all inf are the same). I have removed the current driver package, I make sure it is not installed after reboot with pnputil and then try to install the checked one and it says again that it is already imported as oemsomething.inf (even pnputil keeps not listing it) and get the retail version installed again. Please help.
    Monday, November 12, 2012 9:58 PM