none
Certificate removed from personal store WCF Service with SSL (HTTPS) RRS feed

  • Question

  • Some strange behavior noticed..

    After setting up my machine to use a SSL Certificate to be used for a WCF service hosted with HTTPS endpoint (SSL) in my dev environment. After each run or debug on Visual Studio i see the certificate from personal store is getting removed or deleted.

    Has anyone seen this behavior?

    Thanks,

    Austin

    • Moved by Carl Cai Wednesday, July 31, 2013 7:23 AM offtopic
    Tuesday, July 30, 2013 7:28 AM

All replies

  • Hi AustinAjit,

    This forum is to discuss problems of Diagnostics development. Your question is not related to the topic of this forum.

    I moved it here for more efficient responses. Thanks.

    Carl Cai
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, July 31, 2013 7:24 AM
  • Thanks Carl...

    One more weird observation. It is happening only on my Windows 7 box and not on my Windows 8 box...? thoughts?

    Monday, August 5, 2013 10:52 PM
  • Hi AustinAjit,

    Based on your description, on a Windows 7 dev machine, you found that some SSL certificate you put in personal store will be automatically removed after running a WCF service (which uses the SSL certificate), correct?

    For WCF service, it can use x509 certificate for both transport or message layer security purpose (as service certificate in most cases). However, such configuration will only add certificate reference information in the configuration file so that the runtime can locate the certificate in cert store. And it is definitely unexpected that WCF program will cause the certificate be deleted. For the Windows 7 machine, how did you check the certificate? Are you using the MMC certificate console or using some tools like Windows Powershell? You can try various means to lookup the certificate  store.

    In addition, since the problem occurs after you execute the WCF program, have you tried creating a simplified WCF console app which also configure to use x509 certificate to see if the same behavior remains?

    For operating system layer, I suggest you also check the Windows event log (both application and system) to see if there is any special log entries indicate some problems with the certificate store.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, August 8, 2013 6:58 AM
    Moderator
  • thanks Steven...

    One more correction to my previous comment. Windows 8 is also having the same behavior. I understand that WCF is only having the reference of the cert and should not be the cause of Concern.

    I was wondering this may be because of my Visual Studio Unit Test which loads the process and does some debugging. Still not able to see the pattern nailed down. Will lookup on my event log and post the update.

    Thursday, August 8, 2013 4:43 PM