none
WCF-OracleDB adapter error RRS feed

  • Question

  • Hi,

    I am using Biz Talk Server 2006 R2 on Windows Server 2008 Standart (64 bit). I have installed Biz Talk Adapter Pack 2.0 and Oracle Client 11g. 

    When I try to add a WCF-OracleDB send port in my project, I get following error.

    Could not load file or assembly 'Oracle.DataAccess, Version=2.111.7.0, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The system cannot find the file specified.

    I see that Oracle.DataAccess.dll with above PublicKeytoken present in GAC.

    Please advice. Thanks in advance.

    Nuku.
    Tuesday, April 26, 2011 7:37 AM

Answers

  • Hi,

    For Oracle using BizTalk Adapter Pack 2.0:

    • Supported server versions: Oracle database version 11.1, Oracle database version 10.2, Oracle database version 10.1, Oracle database version 9.2

    • Supported client versions: Oracle Data Access Components for Oracle Client 11.1.0.6 with Patch Set 11.1.0.7

    When installing on x64 platform for BizTalk runtime

    For a 32-bit BizTalk process:

    • Install 32-bit WCF LOB Adapter SDK.

    • Install 32-bit BizTalk Adapter Pack.

    • Install 32-bit LOB client and other required DLLs.

    For a 64-bit BizTalk process:

    • Install 64-bit WCF LOB Adapter SDK.

    • Install 64-bit BizTalk Adapter Pack.

    • Install 64-bit LOB client and other required DLLs.

    You must install 32-bit adapter when performing design-time tasks, using either Visual Studio or BizTalk MMC!

    Reference Install guide BizTalk Adapter Pack 2.0. I would advice the appropriate Oracle client according the guide.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk
    Tuesday, April 26, 2011 11:23 AM
    Moderator

All replies

  • Hi Nuku,

    This can be annoying error. You can read my blogpost BizTalk Adapter Pack 2.0: OracleBinding around this or this thread on forums.  You can also read my article in hotrod 8.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly

     


    BizTalk
    Tuesday, April 26, 2011 7:45 AM
    Moderator
  • I don`t have Visual Studio on this machine. I try add a WCF-OracleDB send port in BizTalk Server Administration!

    In Oracle Net Configuration Assistant test to db instance - is OK!


    My configuration:

    Windows 2008 R2 SP1 x64 Standart
    MSSQL 2008 R2 x64
    BizTalk 2010 x64
    Oracle 11g Client 11.2.0 x64

    Tuesday, April 26, 2011 8:39 AM
  • 'Oracle.DataAccess, Version=2.111.7.0, Culture=neutral, PublicKeyToken=89b483f429c47342' is present in the GAC!

    Any ideas?

    Tuesday, April 26, 2011 10:45 AM
  • Hi,

    For Oracle using BizTalk Adapter Pack 2.0:

    • Supported server versions: Oracle database version 11.1, Oracle database version 10.2, Oracle database version 10.1, Oracle database version 9.2

    • Supported client versions: Oracle Data Access Components for Oracle Client 11.1.0.6 with Patch Set 11.1.0.7

    When installing on x64 platform for BizTalk runtime

    For a 32-bit BizTalk process:

    • Install 32-bit WCF LOB Adapter SDK.

    • Install 32-bit BizTalk Adapter Pack.

    • Install 32-bit LOB client and other required DLLs.

    For a 64-bit BizTalk process:

    • Install 64-bit WCF LOB Adapter SDK.

    • Install 64-bit BizTalk Adapter Pack.

    • Install 64-bit LOB client and other required DLLs.

    You must install 32-bit adapter when performing design-time tasks, using either Visual Studio or BizTalk MMC!

    Reference Install guide BizTalk Adapter Pack 2.0. I would advice the appropriate Oracle client according the guide.

    HTH

    Regards,

    Steef-Jan Wiggers
    MVP & MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk
    Tuesday, April 26, 2011 11:23 AM
    Moderator
  • I have installed 32bit oracle client, and all works! Thanks!
    Tuesday, April 26, 2011 12:10 PM