none
HTTP/1.1 500 Server Error RRS feed

  • Question

  •  

    Hello- I am having a problem creating a new asp.net web application with Visual Studio 2003. When I click New Project and then choose ASP.NET Web Application, I get the following error:

     

    http://localhost/WebApplication1 HTTP/1.1 500 Server Error

     

    I have uninstalled IIS, Visual Studio, Framework, reinstalled a number of times, I have tried regiis.exe /i - basically all of the suggestions from the hundreds of posts on this issue.

     

    I simply want to use Visual Studio to create a new web project and am baffled why getting this to work is so difficult.

     

    Any help would be so much appreciated.

     

    Dan COoley

    Thursday, September 20, 2007 2:53 PM

All replies

  • Dan,

    I am going to assume you get this error after the project has been created - when you try to view it.  What happens if you right-click on your project and choose 'View in Browser'?

    Also, you may want to go into IE, and choose Tools >> Internet Options >> Advanced, and untick the checkbox for 'Show friendly HTTP error messages'.  After doing this, do you see a different error?

    Hope this helps,


    Steve - dotneticated.com
    Sunday, September 23, 2007 11:04 PM
  • I'm having the exact same problem as Dan. Please read his post fully. When he creates a new web project by clicking the New Project button on the VS 2003 start page -> projects tab, he and I both immediately get the error message http://localhost/ApplicationName HTTP/1.1 500 Server Error. This message is delivered by Visual Studio .Net 2003. So unchecking that friendly box does not help. Plus the projects tab does not allow right clicks on any of the project links. It's not a firewall or anti-virus either. This is my third day trying to get past this error and I'm growing unhappier each day. Does anyone out there have a real solution?
    Wednesday, October 10, 2007 8:26 PM
  • Okay, I finally found the solution that fixed the problem on my system. There seem to be about 10 different solutions out there. Larkpics posted the below solution at
    http://www.velocityreviews.com/forums/t112042-url-httplocalhostwebproject1-http11-500-server-error.html


    PROBLEM SOLVED! When you are going round and round, you end up
    corrupting your installation of .NET Framework. To fix this, load your
    Prerequisites disc and Start > Run >

    E:\dotNetFramework\dotnetfx.exe /t:c:\temp /c:"msiexec.exe /fvecms c:\temp\netfx.msi"

    when E: is the drive letter of the disc.



    Wednesday, October 10, 2007 11:21 PM