none
How to navigate to the function declaration RRS feed

  • General discussion

  • Hi I am kinda new to the visual studio.

    I have a project in C language. There are few function declarations in the code which are located in different parts of the files. I am unable to navigate to that location where the function or variable is declared. Can I know how to enable it ?

    I am using microsoft visual studio 2008 version 9.0.30729.1 SP
     
    Thanks in advance
    Sunday, July 26, 2009 4:50 AM

All replies

  • try open it manually from the project file .. You should have project.h and project.c and other files are visual studio files if you found any... If you are unable to navigate, it seems something is missing.
    Sunday, July 26, 2009 8:58 AM
  • Quote>I am unable to navigate to that location where the function or variable is declared.

    Describe what you have tried, and what happened.

    - Wayne
    Sunday, July 26, 2009 4:26 PM
  • Have you tried to right click and then choose "Go to declaration" or "Go to definition"?
    http://blog.voidnish.com
    Sunday, July 26, 2009 4:33 PM
    Moderator
  • I opened all the source and header files in the folder. In a source file there are many functions which are declared in many header files. I then highlight the function right click it and then select go to declaration or go to definition, VS says the symbol "....." is not defined. 
    Sunday, July 26, 2009 5:48 PM
  • Does this happen with all projects, or only one/some?

    Have you tried a "Clean" from the Build menu or project pop-up menu?

    Have you tried manually deleting the *.ncb file? (Close the solution, navigate to the project
    directory using Explorer or equivalent, delete the *.ncb file, reopen the solution/project.)

    - Wayne
    Sunday, July 26, 2009 6:40 PM
  • We are changing the issue type to “General Discussion” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by opening the Options list at the top of the post window, and changing the type. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions.

    Thank you!
    Rong-Chun Zhang
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Friday, July 31, 2009 8:30 AM
  • Its a pure C project. Its not  Visual C++ project. I am unable to open that way but my friend who has the same version of Visual C++ is able to open the declaration and stuff.
    Friday, July 31, 2009 8:35 AM