locked
"Cannot insert object" Excel 2013 Pro Plus: Forms 2.0 RRS feed

  • Question

  • I have been working for weeks on a macro enabled Excel workbook that relies heavily on MS Forms 2.0 and VBA to operate.

    Early on the morning of December 10, 2013, Microsoft Update installed a couple dozen critical updates.

    Now, all of the ActiveX controls are broken, including the VBA.  I see them on the sheets, but it's as if they don't exist.

    When I try to insert an ActiveX, I get the message "Cannot insert object"

    Anyone have a solution? This is a devastating development to my solution!

    **** Update 20131210 ****

    Solved: Performed these operations



      • Unhide protected system files

      • Browse to C:\Users\USERNAME\AppData\Local\Temp

      • Delete all files

      • Hide protected system files

      • Restart Excel




    1. Unhide protected system files

    2. Browse to C:\Users\USER NAME\AppData\Local\Temp

    3. Delete all files

    4. Hide protected system files

    5. Restart Excel


    • Edited by reengle Wednesday, December 10, 2014 5:32 PM Solved
    Wednesday, December 10, 2014 5:13 PM

Answers

  • I have Windows 8 running Office 2007.  I could not find "MSForms.exd".  But I ran free version of CCleaner (which empties temp locations), after I checked the advance settings to make sure "only delete if older than 24hrs" was SWITCHED OFF, and...

     

    PROBLEM SOLVED ! ! ! 

     

    I use the free AI List (Action Item List) from www.ExcelAutomationHelp.com daily, it couldn't group-sort until I fixed this.  Made me realize how awesome group-sorting lists is.
    Wednesday, December 10, 2014 11:49 PM
  • Hi Reegle,

    Here is the latest blog for this issue:
    Form Controls stop working after December 2014 Updates

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 15, 2014 7:47 AM

All replies

  • I have Windows 8 running Office 2007.  I could not find "MSForms.exd".  But I ran free version of CCleaner (which empties temp locations), after I checked the advance settings to make sure "only delete if older than 24hrs" was SWITCHED OFF, and...

     

    PROBLEM SOLVED ! ! ! 

     

    I use the free AI List (Action Item List) from www.ExcelAutomationHelp.com daily, it couldn't group-sort until I fixed this.  Made me realize how awesome group-sorting lists is.
    Wednesday, December 10, 2014 11:49 PM
  • Hi Reengle,

    Please try the suggestion provide by FishTail to see whether the issue was resolved.

    Also we have reported this problem and will keep you updated once there's any progress.

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, December 12, 2014 8:32 AM
  • Hi Reegle,

    Here is the latest blog for this issue:
    Form Controls stop working after December 2014 Updates

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 15, 2014 7:47 AM
  • Hi Reegle,

    Here is the latest knowlege base for this issue:

    https://support.microsoft.com/kb/3025036/EN-US?wa=wsignin1.0

    Regads & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 22, 2014 1:38 AM