none
Sp2013 products preparation tool running more than 3 hours

    Question

  • hello all,

    im installing Sp2013, first i run "Prerequisites", it failed due to "The tool was unable to install Web Server " reason so, i went to "C:\Windows\System32\" copy and paste "servermanager.exe" then renamed the pasted file name as "ServerManagerCMD.exe" then again run "Prerequisites" this time it start installing, at one stage it opend ServerManager window, then it keeps on says "Configuring Application Server Role, Web Server (IIS) Role more than 3 hours

    if i close the Server Manager window then it says "failed to install Prerequisites"

    then again i run "prerequisites" again it opens Server Manager and shows "configuring application server role"...

    refer below screenshot.

    may i know why it keeps on running? why server manager shows Red color and how to identify why this takes long time?

    Monday, April 15, 2019 4:11 PM

Answers

  • For .NET 3.5, you have to specify an alternative source installation path when installing it via server manager. This should point at the SxS folder on your Win 2012 R2 ISO.

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by winseelan Monday, April 22, 2019 2:35 PM
    Monday, April 22, 2019 2:04 PM
    Moderator

All replies

  • If you had to do anything manually, you've done it wrong :-)

    It sounds like you're attempting to install SharePoint 2013 on Windows Server 2012 R2. If that is the case, you must download the 'SharePoint 2013 *with* Service Pack 1' ISO. That ISO is supported for Windows Server 2012 R2 and will install without you having to do anything manual.


    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Monday, April 15, 2019 4:28 PM
    Moderator
  • Hi

    Maybe your server cpu or memory is low too much.


    Please remember to mark the replies as answers if they helped.
    Linyu - SharePoint Engineer
    QQ Group: 72637444

    Tuesday, April 16, 2019 1:05 AM
  • Hi Itch Sun

    as per your idea, i downloaded Sp2013 service pack1 but, its not ISO file, its exe only; from https://www.microsoft.com/en-us/download/confirmation.aspx?id=42544

    then i try install it but, it says "there is no products affected by this install...."

    may i do know what shall i do next?

    thanks

    jey

    Tuesday, April 16, 2019 2:00 PM
  • hi Linyu

    actually the server is not slow because, months back i already installed SP2013 on the same server

    thaks

    jey

    Tuesday, April 16, 2019 2:01 PM
  • Hi Itch Sun

    as per your idea, i downloaded Sp2013 service pack1 but, its not ISO file, its exe only; from https://www.microsoft.com/en-us/download/confirmation.aspx?id=42544

    then i try install it but, it says "there is no products affected by this install...."

    may i do know what shall i do next?

    thanks

    jey


    That's not sufficient. You must download the SharePoint Server 2013 *with* Service Pack 1 ISO. See https://support.microsoft.com/en-us/help/2891274/sharepoint-2013-sp1-support-in-windows-server-2012-r2. The setup program was changed in this ISO release to support 2012 R2 which is why you cannot just patch a 2013 RTM install for 2012 R2 support.

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, April 16, 2019 2:52 PM
    Moderator
  • Hi winseelan,

    Has the problem been solved?
    If you have the replies is helpful to you, please remember to mark them as answers. It would help others who meet the similar question at this forum.
    Thank you for your understanding.

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Thursday, April 18, 2019 1:26 AM
  • actually the problem is not solved.

    now im trying to install Sp2013 in new Windows Server 2012 (no R2) but, im receiving error as below

    below is the log file from Sp 2013 prerequiste installation

    2019-04-22 13:19:18 - Request for install time of Application Server Role, Web Server (IIS) Role
    2019-04-22 13:19:18 - Install process returned (0)
    2019-04-22 13:19:18 - [In HRESULT format] (0)
    2019-04-22 13:19:18 - "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe" -i
    2019-04-22 13:19:18 - Install process returned (0)
    2019-04-22 13:19:18 - [In HRESULT format] (0)
    2019-04-22 13:19:18 - "C:\Windows\system32\cscript.exe" "C:\Windows\system32\iisext.vbs" /enext "ASP.NET v4.0.30319"
    2019-04-22 13:19:18 - Install process returned (1)
    2019-04-22 13:19:18 - [In HRESULT format] (-2147024895)
    2019-04-22 13:19:18 - Error when enabling ASP.NET v4.0.30319
    2019-04-22 13:19:18 - Last return code (1)
    2019-04-22 13:19:18 - Reading the following DWORD value/name...
    2019-04-22 13:19:18 - Flags
    2019-04-22 13:19:18 - from the following registry location...
    2019-04-22 13:19:18 - SOFTWARE\Microsoft\Updates\UpdateExeVolatile
    2019-04-22 13:19:18 - Reading the following string value/name...
    2019-04-22 13:19:18 - PendingFileRenameOperations
    2019-04-22 13:19:18 - from the following registry location...
    2019-04-22 13:19:18 - SYSTEM\CurrentControlSet\Control\Session Manager
    2019-04-22 13:19:18 - Reading the following registry location...
    2019-04-22 13:19:18 - SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired
    2019-04-22 13:19:18 - Error: The tool was unable to install Application Server Role, Web Server (IIS) Role.
    2019-04-22 13:19:18 - Last return code (1)
    2019-04-22 13:19:18 - Options for further diagnostics: 1. Look up the return code value 2. Download the prerequisite manually and verify size downloaded by the prerequisite installer. 3. Install the prerequisite manually from the given location without any command line options.
    2019-04-22 13:19:18 - Cannot retry
    2019-04-22 13:19:18 - Check whether the following prerequisite is installed:
    2019-04-22 13:19:18 - Windows Management Framework 3.0
    2019-04-22 13:19:18 - Reading the following string value/name...
    2019-04-22 13:19:18 - PowerShellVersion
    2019-04-22 13:19:18 - from the following registry location...
    2019-04-22 13:19:18 - SOFTWARE\Microsoft\PowerShell\3\PowerShellEngine
    2019-04-22 13:19:18 - The value is... 
    2019-04-22 13:19:18 - 3.0
    2019-04-22 13:19:18 - Reading the following string value/name...
    2019-04-22 13:19:18 - CTPVersion
    2019-04-22 13:19:18 - from the following registry location...
    2019-04-22 13:19:18 - SOFTWARE\Microsoft\PowerShell\3\PowerShellEngine
    2019-04-22 13:19:18 - Could not find or unable to read CTPVersion key
    2019-04-22 13:19:18 - The prerequisite above is already installed
    2019-04-22 13:19:18 - Check whether the following prerequisite is installed:
    2019-04-22 13:19:18 - Microsoft .NET Framework 4.5
    2019-04-22 13:19:18 - Reading the following DWORD value/name...
    2019-04-22 13:19:18 - Install
    2019-04-22 13:19:18 - from the following registry location...
    2019-04-22 13:19:18 - SOFTWARE\Microsoft\Net Framework Setup\NDP\V4\full
    2019-04-22 13:19:18 - The value is (1)
    2019-04-22 13:19:18 - Reading the following string value/name...
    2019-04-22 13:19:18 - Version
    2019-04-22 13:19:18 - from the following registry location...
    2019-04-22 13:19:18 - SOFTWARE\Microsoft\Net Framework Setup\NDP\V4\full
    2019-04-22 13:19:18 - The value is... 
    2019-04-22 13:19:18 - 4.5.50709
    2019-04-22 13:19:18 - The release version of .NET 4.5 is installed.
    2019-04-22 13:19:18 - Check whether the following prerequisite is installed:
    2019-04-22 13:19:18 - Microsoft Sync Framework Runtime v1.0 SP1 (x64)
    2019-04-22 13:19:18 - Reading version of the following file...
    2019-04-22 13:19:18 - C:\Windows\assembly\GAC_MSIL\Microsoft.Synchronization\1.0.0.0__89845dcd8080cc91\Microsoft.Synchronization.dll
    2019-04-22 13:19:18 - GetFileVersionInfoSize failed (-2147024894)
    2019-04-22 13:19:18 - Check whether the following prerequisite is installed:
    2019-04-22 13:19:18 - Microsoft SQL Server 2008 R2 SP1 Native Client
    2019-04-22 13:19:18 - Reading the following string value/name...
    2019-04-22 13:19:18 - Version
    2019-04-22 13:19:18 - from the following registry location...
    2019-04-22 13:19:18 - SOFTWARE\Microsoft\Microsoft SQL Server\SQLNCLI10\CurrentVersion
    2019-04-22 13:19:18 - Check whether the following prerequisite is installed:
    2019-04-22 13:19:18 - Windows Server AppFabric
    2019-04-22 13:19:18 - Reading the following string value/name...
    2019-04-22 13:19:18 - ProductVersion
    2019-04-22 13:19:18 - from the following registry location...
    2019-04-22 13:19:18 - SOFTWARE\Microsoft\AppFabric\V1.0
    2019-04-22 13:19:18 - Check whether the following prerequisite is installed:
    2019-04-22 13:19:18 - Windows Identity Foundation (KB974405)
    2019-04-22 13:19:18 - Reading the following string value/name...
    2019-04-22 13:19:18 - 
    2019-04-22 13:19:18 - from the following registry location...
    2019-04-22 13:19:18 - SOFTWARE\Microsoft\Microsoft Identity Extensions\Setup\1.0
    2019-04-22 13:19:18 - Check whether the following prerequisite is installed:
    2019-04-22 13:19:18 - Microsoft Information Protection and Control Client
    2019-04-22 13:19:18 - Reading the following string value/name...
    2019-04-22 13:19:19 - 
    2019-04-22 13:19:19 - from the following registry location...
    2019-04-22 13:19:19 - SOFTWARE\Microsoft\MSIPC\CurrentVersion
    2019-04-22 13:19:19 - Check whether the following prerequisite is installed:
    2019-04-22 13:19:19 - Microsoft WCF Data Services 5.0
    2019-04-22 13:19:19 - Reading the following string value/name...
    2019-04-22 13:19:19 - Version
    2019-04-22 13:19:19 - from the following registry location...
    2019-04-22 13:19:19 - SOFTWARE\Wow6432Node\Microsoft\Microsoft WCF Data Services\5.0
    2019-04-22 13:19:19 - Check whether the following prerequisite is installed:
    2019-04-22 13:19:19 - Cumulative Update Package 1 for Microsoft AppFabric 1.1 for Windows Server (KB2671763)
    2019-04-22 13:19:19 - Reading the following DWORD value/name...
    2019-04-22 13:19:19 - IsInstalled
    2019-04-22 13:19:19 - from the following registry location...
    2019-04-22 13:19:19 - SOFTWARE\Wow6432Node\Microsoft\Updates\AppFabric 1.1 for Windows Server\KB2671763
    2019-04-22 14:01:13 - Opening log file
    2019-04-22 14:01:13 - Opened action for user

    i googled and people said, i have to install .net framework from Server Manager, then i tried to install it but, i received below error message

    .net 3.5 features

    Experts please help me to resolve this issue.

    thanks

    jey

    Monday, April 22, 2019 1:12 PM
  • For .NET 3.5, you have to specify an alternative source installation path when installing it via server manager. This should point at the SxS folder on your Win 2012 R2 ISO.

    Trevor Seward

    Office Servers and Services MVP



    Author, Deploying SharePoint 2016

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by winseelan Monday, April 22, 2019 2:35 PM
    Monday, April 22, 2019 2:04 PM
    Moderator