none
TimesheetLine ODATA query is failing RRS feed

  • Question

  • Helo,

    while trying to query the TimesheetLine via ODATA in PowerBI, it always fails with the same error.

    DataFormat.Error: We detected an invalid reader state 'Exception' when processing request 'https://<URL>/_api/Projectdata/TimesheetLines?$top=200'.
    Details:
        <a href="https:///_api/Projectdata/TimesheetLines?$top=200">https://<URL>/_api/Projectdata/TimesheetLines?$top=200

    What is causing this or how can I troubleshoot more what could be the reason for the problem?

    Thanks

    Joerg

    Thursday, April 19, 2018 3:07 PM

All replies

  • Hello Joerg.

    Are you querying other collections succesfully?

    When diagnosing this kind of problems, I usually start at the basic which would be querying the Projects collection with no attributes.

    Try: https://<url>/_api/ProjectData/Projects and check if that query gives you any error and start from there.

    Hope it helps.


    Rene Alvarez

    Wednesday, April 25, 2018 7:59 PM
  • HI,

    Other collections like Project or Resources are working fine. Its only the TImesheetLine collection which is not working.

    Additional, this is not working against any of our PWA sites.

    Joerg

    Thursday, April 26, 2018 8:08 AM
  • Hello,

    Any update on this? I m too facing this issue.

    Any help will be appreciated

    Regards,

    Amay Singh

    Friday, June 22, 2018 10:05 AM
  • This worked for me, however, please note the capitalisation of ProjectData in the URL (not Projectdata).  This may or may not be your issue, but this URL is fine (though of course you'll need passwords to verify) - I've pasted it here so that you can cut and paste it EXACTLY and then just change the organisation and site name to match your organisation and site name.

    https://mvpapplepark.sharepoint.com/sites/pspwa/_api/ProjectData/Timesheets?$top=200


    Ben Howard [MVP] | web | blog | book | downloads | P2O

    Friday, June 22, 2018 2:45 PM
    Moderator
  • Hi Ben,

    Thank you. Above query is working for Timesheets Table. (This table was working fine for me)

    However, i am facing issues with Timesheetline Table. Still same error when tried above query

    Regards,

    Amay Singh

    Friday, June 22, 2018 4:37 PM
  • Hello,

    Any update on this. i m still facing this issue.

    Regards,

    Amay Singh

    Wednesday, July 18, 2018 9:09 AM