locked
Package.appxmanifest claims I don't have a file

    Question

  • I am trying to build the App Package for my Windows Phone 8.1 app. When I try to do this, I receive the following error:

    App manifest references the image 'Assets\SplashScreen.png' which does not have a candidate in main app package.

    I have the file in my Assets folder, so I cannot figure out why it cannot access it. What do I need to do?


    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Wednesday, October 01, 2014 7:48 PM

Answers

All replies

  • Hi Nathan,

    I deleted the scale 240 image and then use the scale 100 image as the splash screen image, the app worked on my emulator. You can see my setting from the following image. I cannot repro your issue.

    Can you build a new project to follow this quickstart? If it doesn’t work either, please post the project here, I will look into it to find what happened. Use your OneDrive and share a link.

    Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, October 02, 2014 6:45 AM
    Moderator
  • The emulator is unrelated to my problem, I can run the emulator just fine. The problem is when I attempt to build an App Package. One thing I did notice when looking at the xml code for Package.appxmanifest was that it uses a different xml namespace than the one at

    http://msdn.microsoft.com/en-us/library/windows/apps/xaml/Hh973049(v=win.10).aspx

    They say to use:

    <m2:SplashScreen Image="Assets\SplashScreen.png" /
    While my Package.appxmanifest uses:
    <m3:SplashScreen Image="Assets\SplashScreen.png" BackgroundColor="transparent" />
    I wouldn't think this would make a difference, I think that my version of Visual Studio 2013 is just more updated that the documentation on the page. But either way, the file was created using the Visual Studio 2013 tool, and it has worked in the past. And once again, I am able to use the emulator, the problem does not occur until I attempt to build the App Package. Any other ideas? Thanks.

    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Thursday, October 02, 2014 3:59 PM
  • I still don't know exactly what caused the problem, but I found a workaround at:

    http://social.msdn.microsoft.com/Forums/en-US/3857fb9d-dbd5-4eb8-aa75-fe4c47f26875/wp81-universal-error-image-does-not-have-a-candidate-in-main-app-package-while-creating-a-package?forum=WindowsPhonePreviewSDK

    The workaround tells you to set the Generate App Bundle setting to Never. Once I did this, it worked. But I have never needed to do this before, so I must have somewhere done something different. But it's good enough for now.


    Nathan Sokalski njsokalski@hotmail.com http://www.nathansokalski.com/

    Thursday, October 02, 2014 11:02 PM