locked
Requested Registry access is not allowed RRS feed

  • Question

  • I have a SL app with Ria Services that has been running fine in the VS 10 Dev Env for some time.

    Today, however, one I first tried running it, it came back with "Access is Denied" to the temp ASPNet folder when the site first starts up in the Dev Server.  After some googling, it said to grant permissions to the Network Service to the folder which I did and it resolved that error.

    But now I get another one: "Registry Access is now allowed"

    The line of code that bombs is not my code:

      System.Web.dll!System.Web.Util.Misc.GetAspNetRegValue(string subKey, string valueName = null, object defaultValue = null) + 0x25 bytes 

    I have don't understand what happened.  I did not make any changes to the system.  I am logged in as an Admin on the local machine and as an Admin on the domain.  I even tried a system restore - no luck.

    Note, however, if I create a brand new project it runs as expected.

    My backup projects also fail to run which had been running earlier.

    Any suggestions?

    Greg

    Tuesday, June 1, 2010 6:49 PM

Answers

  • OK, got this resolved by starting up VS as an administrator.  Still not sure why this suddenly showed up. Oh well.

    Tuesday, June 1, 2010 7:12 PM