none
HTTP Send Port: The remote server returned an error: (401) Unauthorized RRS feed

  • Question

  • Dear Friends,

    we have newly installed and configured BizTalk 2013 R2 with SHA2 cert support updated package. we are getting below error message when we sending XML file via HTTP Send Port.

    we have not configured IIS, we have installed BizTalk at DMZ. Please advice as its bit urgent. Thanks in advance.

    The adapter failed to transmit message going to send port "SXXSendPort" with URL "https://sweb0.abc.com.sg:443/invoke/sweb.ib/Receive". It will be retransmitted after the retry interval specified for this Send Port. Details:"The remote server returned an error: (401) Unauthorized.".

    Wednesday, March 2, 2016 10:48 AM

Answers

  • Hello,

    The HTTP Code 401 can have a lot of reasons.

    As you are using HTTPS it could be possible that your certificate is not correct. In order to find what's going wrong, you only need to enable in IIS the Failed Request Logging (specify the range from 400 - 500 to insure that the 401 is not a result of a 400 Bad Request, or 500 Internal Server Error.

    Documentation : http://www.iis.net/learn/troubleshoot/using-failed-request-tracing/troubleshooting-failed-requests-using-tracing-in-iis

    Now reproduce the issue and you will find a trace file on your local drive : C:\inetpub\... failed request ...

    Open it and take a look at the response section at the end. You will find your 401 with a sub code. This sub code will help you find the solution :-)

    Best regards,


    Steve Melan - BCEE My Blog : http://stevemelan.wordpress.com

    • Proposed as answer by Angie Xu Friday, March 11, 2016 2:36 AM
    • Marked as answer by Angie Xu Sunday, March 13, 2016 7:43 AM
    Tuesday, March 8, 2016 6:01 PM

All replies

  • Hi Soori,

    Thank you for posting on MSDN forum.

    Please have a look into below article, that might be helpful for your issue.

    http://kentweare.blogspot.in/2011/03/biztalk-2010-calling-dynamics-crm-40.html


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, March 3, 2016 7:12 PM
  • The error "The remote server returned an error: (401) Unauthorized" clearly states its an authorization issue.

    Are you able to browse the webservice? Please confirm the user under which the adapter host is running has all the rights on the web site.

    Refer: WCF Service:The remote server returned an error: (401) Unauthorized.

    If authentication settings of the service in IIS looks like shown at the picture below, you will get the error shown above.

    image 

    If you for example disable the WindowsAuthentication, the client will authenticate successfully by using of 
    Basic-Transport-Authentication.



    Rachit Sikroria (Microsoft Azure MVP)

    Friday, March 4, 2016 7:14 AM
    Moderator
  • Hello,

    The HTTP Code 401 can have a lot of reasons.

    As you are using HTTPS it could be possible that your certificate is not correct. In order to find what's going wrong, you only need to enable in IIS the Failed Request Logging (specify the range from 400 - 500 to insure that the 401 is not a result of a 400 Bad Request, or 500 Internal Server Error.

    Documentation : http://www.iis.net/learn/troubleshoot/using-failed-request-tracing/troubleshooting-failed-requests-using-tracing-in-iis

    Now reproduce the issue and you will find a trace file on your local drive : C:\inetpub\... failed request ...

    Open it and take a look at the response section at the end. You will find your 401 with a sub code. This sub code will help you find the solution :-)

    Best regards,


    Steve Melan - BCEE My Blog : http://stevemelan.wordpress.com

    • Proposed as answer by Angie Xu Friday, March 11, 2016 2:36 AM
    • Marked as answer by Angie Xu Sunday, March 13, 2016 7:43 AM
    Tuesday, March 8, 2016 6:01 PM