locked
Code Analysis Error CA0001: An unknown error occurred while running Code Analysis RRS feed

  • Question

  • I have inherited a rather large and old code base. I'm interested in running code analysis to identify dead code. There's lots of it and it's driving me crazy.

    I'm getting the error in the title, which I've had no luck finding in Microsoft's documentation or any other reference to it on the web. I can get code analysis to run on similar, new projects in the solution with newer code.

    I suspect it may be a problem with the project file itself or older items included in the project. I'm just looking for any kind of hint on where to start since the error occurs at a high level, doesn't generate the CodeAnalysisReport.xml file and gives me no clue.

    Other pertinent details. FXCop isn't involved. We aren't using it... yet. Doesn't matter which rule set I try to run or which build configuration. Project is set to framework 4.0. Project in question has both Service References, Web References, strongly typed datasets, and cs files. Project file does complain about schema in some areas but haven't been able to identify that is the problem. Have tried cleaning up schema complaints in project file to no avail.

    Any ideas are appreciated! Thanks! Back to manually going through the files to look for refs :(

    Tuesday, November 6, 2012 7:43 PM

Answers

  • Hi Arhiannas,

    Thank you for posting in the MSDN forum.

    Would you mind sharing us the detailed error message?

    CA0001

    There are a few reasons which would generated this issue, I have met this error, it is related to the assembly which is referenced or the build type like this thread “CA0001”, if possible, you could refer it, hope it could help.

    If possible, you could share us a sample, we try to check it in our Environment. Thanks for your understanding.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us


    Thursday, November 8, 2012 8:02 AM
    Moderator

All replies

  • Hi Arhiannas,

    Thank you for posting in the MSDN forum.

    Would you mind sharing us the detailed error message?

    CA0001

    There are a few reasons which would generated this issue, I have met this error, it is related to the assembly which is referenced or the build type like this thread “CA0001”, if possible, you could refer it, hope it could help.

    If possible, you could share us a sample, we try to check it in our Environment. Thanks for your understanding.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us


    Thursday, November 8, 2012 8:02 AM
    Moderator
  • Hi Arhiannas,

    I am writing to check the status of the issue on your side. 

    What about this problem now?

    Would you mind letting us know more information about this issue?

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, November 13, 2012 2:16 AM
    Moderator