locked
Problems with Vs2013 Express for Windows

    Question

  • Hello, I'm new to .Net and C# programming and this is my first question on the forum.

    I've just installed Vs2013 Express for Windows and created Blank App(Xaml), first of all designer failed to load and it threw

    System.Runtime.InteropServices.COMException , The app didn't start. (Exception from HRESULT: 0x8027025B).

    If you aren't lazy to read, here's the full exception:

    ////////

    System.Runtime.InteropServices.COMException
    The app didn't start. (Exception from HRESULT: 0x8027025B)
       at Microsoft.Expression.HostUtility.AppPackage.AppPackageNativeMethods.IApplicationActivationManager.ActivateApplication(String appUserModelId, String activationContext, ActivateOptions options, Int32& processId)
       at Microsoft.Expression.HostUtility.AppPackage.WrtUtility.ActivateApplication(String appUserModelId, String activationContext, Object site)
       at Microsoft.Expression.HostUtility.Platform.AppContainerProcessDomainFactory.ActivateApplicationInternal(String appUserModelId, String activationContext, Object site)
       at Microsoft.Expression.HostUtility.Platform.AppContainerProcessDomainFactory.CreateDesignerProcess(String applicationPath, String clientPort, Uri hostUri, IDictionary environmentVariables, Int32& processId, Object& processData)
       at Microsoft.Expression.DesignHost.Isolation.Primitives.ProcessDomainFactory.ProcessIsolationDomain..ctor(ProcessDomainFactory factory, IIsolationBoundary boundary, AppDomainSetup appDomainInfo, FrameworkName targetFramework, String identifier, String baseDirectory)
       at Microsoft.Expression.DesignHost.Isolation.Primitives.ProcessDomainFactory.CreateIsolationDomain(IIsolationBoundary boundary)
       at Microsoft.Expression.HostUtility.Platform.AppContainerProcessDomainFactory.CreateIsolationDomain(IIsolationBoundary boundary)
       at Microsoft.Expression.DesignHost.Isolation.Primitives.IsolationBoundary.Initialize()
       at Microsoft.Expression.DesignHost.Isolation.Primitives.IsolationBoundary.CreateInstance[T](Type type)
       at Microsoft.Expression.DesignHost.Isolation.IsolatedObjectFactory.Initialize()
       at Microsoft.VisualStudio.ExpressionHost.Services.VSIsolationService.CreateObjectFactory(IIsolationTarget isolationTarget, IObjectCatalog catalog)
       at Microsoft.Expression.DesignHost.Isolation.IsolationService.CreateLease(IIsolationTarget isolationTarget)
       at Microsoft.Expression.DesignHost.IsolatedDesignerService.CreateLease(IIsolationTarget isolationTarget, CancellationToken cancelToken, DesignerServiceEntry& entry)
       at Microsoft.Expression.DesignHost.IsolatedDesignerService.IsolatedDesignerView.CreateDesignerViewInfo(CancellationToken cancelToken)
       at Microsoft.Expression.DesignHost.Isolation.IsolatedTaskScheduler.InvokeWithCulture[T](CultureInfo culture, Func`2 func, CancellationToken cancelToken)
       at Microsoft.Expression.DesignHost.Isolation.IsolatedTaskScheduler.<>c__DisplayClassa`1.<StartTask>b__6()
       at System.Threading.Tasks.Task`1.InnerInvoke()
       at System.Threading.Tasks.Task.Execute()

    /////////////////

    Well after a bit of unsuccessful googling I tried launching application in debug mode, without changing any code and got:

    An unhandled exception of type 'System.Exception' occurred in App2.exe

    Additional information: Could not read key from registry (Exception from HRESULT: 0x80040150 (REGDB_E_READREGDB))

    and then:

    An issue in app process caused it to fail to activate. This process threw one or more or more exceptions.

    I'm using Windows 8.1 and have no problems with Vs2013 express for desktop.

     





    Sunday, March 23, 2014 7:04 PM

Answers

All replies

  • Try reinstalling or repairing vs 2013 express for windows.  It sounds like something did not install properly
    Sunday, March 23, 2014 7:19 PM
  • Hi, thanks for your suggestion. I tried repairing it but with no luck. I will try reinstalling it now.
    Monday, March 24, 2014 2:17 PM
  • Just tried reinstalling still without any luck.
    • Edited by hoome Monday, March 24, 2014 2:41 PM
    Monday, March 24, 2014 2:41 PM
  • Hi,

    May be some problem in your OS. You can try to reinstall Win8.1 and VS2013. Before reinstall, you should clean up the VS2013 installation.

    And you refer the link to get more professional support:

    https://getsupport.microsoft.com/default.aspx?locale=EN-US&supportregion=EN-US&ccfcode=US&mkt=EN-US&pesid=14654&oaspworkflow=start_1.0.0.0&tenant=store&supporttopic_L1=31762110&ccsid=635312883417229196

    Best Wishes!


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey. Thanks<br/> MSDN Community Support<br/> <br/> Please remember to &quot;Mark as Answer&quot; the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    Tuesday, March 25, 2014 3:07 AM
  • Thanks for your suggestion, reinstalling windows did fix it.
    Thursday, March 27, 2014 7:23 PM
  • Seriously your solution is reinstall Windows??????? This must be a joke, reinstall Windows to repair Xaml designer...
    • Edited by BlackCid Monday, February 02, 2015 6:21 PM
    Monday, February 02, 2015 6:20 PM