none
.vsto file not getting invoked for Outlook 2013 addin RRS feed

  • Question

  • hi,

    I just migrated our custom signature addin for Outlook 2013 to VS 2013 and used InstallShield for deployment.

    Everything seems to get created like registry key and all the files under program files:

    Manifest entry:file:///C:\Program Files\[custom app directory]\Office.Outlook.AddIn.EmailSignatures.vsto|vstolocal

    and I have all the relevant files including the .vsto in C:\Program Files\[Custom App Directory]

    The issue I'm facing is the add-in does not get invoked when I start Outlook 2013. I've to manually go in and invoke the .vsto and then it add the Custom Add-in.

    One thing I noticed when I invoke the .vsto I get the following prompt 'cause of the certificate, but I've already installed the certificate. I'm not sure if this the cause of the add-in not getting installed on its own. Is there some way to get rid of this prompt ?

    thanks.

     

    Monday, April 14, 2014 10:02 PM

Answers

All replies

  • Hello,

    There is no need to invoke the .vsto file directly. The add-in should be loaded by the host application.

    Is your add-in listed in the COM add-ins dialog in Outlook?

    Did you have a chance to look at the Registry Entries for Application-Level Add-Ins? Were they added?

    Monday, April 14, 2014 10:47 PM
  • Hi,

    Base on the description, the add-in didn’t load when you start the Outlook application. I found a blog about this issue, please check it whether it is helpful:
    My Office Addin does not Load!

    In addition, I suggest you trying to publish the add-in using ClickOnce to see whether this issue was fixed. You can get more detail about deploy the add-in with ClickOnce from link below:
    Deploying an Office Solution by Using ClickOnce

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, April 15, 2014 9:41 AM
    Moderator
  • yes, I have the registry settings right, specifically the manifest.

    I have all the physical files in the C:\Program Files\Custom Signature folder.

    I checked again using InstallShield deployment, the setup.exe does all the registry settings and creates puts all the files in the C:\Program Files\Custom Signature folder.

    But when I start Outlook, the Add-in is not there. I also checked in Outlook 2013 under

    File -> Options -> Add-Ins. The Add-In is not there.

    Also checked Managed Com-Add-Ins, its not there.

    Now, after this when I go to  C:\Program Files\Custom Signature folder  and double click "Office.Outlook.AddIn.EmailSignatures.vsto", I get the above prompt , "Are you sure you want to install this customization". and then I click Install, and it installs it fine.  After this when I open Outlook 2013, the add-in appears fine and its working. I'm able to see the add-in at File -> Options -> Add-Ins.

    I also tried "ClickOnce" by publishing the addin solution from Visual Studio 2013.

    A setup file gets created in the target publish folder. I ran the setup and it creates the addin in outlook. But I still have to run the InstallShield as it creates the required files in

    C:\Program Files\Custom Signature\    folder.

    If I don't run the "installshield  setup" and just run the "clickonce setup" the addin get added but it complains about some dependent files in C:\Program Files\Custom Signature\ folder.


    • Edited by hsam12 Tuesday, April 15, 2014 3:47 PM
    Tuesday, April 15, 2014 2:32 PM
  • Hello,

    Please make sure that you unregistered your add-in before running any installer.

    I'd recommend to test your installers on separate machines instead. Most probably the registry records don't correspond to the add-in files location. Or try to uninstall the add-in using installers and then try to unregister it from Visual Studio. I suppose add-in records were mixed.

    Wednesday, April 16, 2014 12:31 PM
  • Yes, I have tried on a clean machine from scratch where there was no add-in installed before. I have the same issue, the installer installs the files and puts the registry entries in place. But Outlook does not show up the add-in. But when I then manually go and invoke the .vsto file, the add-in is added perfectly.

    I've also tried to completely uninstall and unregister the add-in and re-install the add-in on my dev and I've the same issue.

    Wednesday, April 16, 2014 1:34 PM
  • If registry keys were added properly you should see the add-in listed in the COM add-ins dialog. Most probably you didn't add the required windows registry keys. Check out the Registry Entries for Application-Level Add-Ins article.

    Also Microsoft Office applications can disable add-ins that behave unexpectedly. If an application does not load your add-in, the application might have hard disabled or soft disabled your add-in.

    Soft disabling can occur when an add-in produces an error that does not cause the application to unexpectedly close. For example, an application might soft disable an add-in if it throws an unhandled exception while the Startup event handler is executing.

    When you re-enable a soft-disabled add-in, the application immediately attempts to load the add-in. If the problem that initially caused the application to soft disable the add-in has not been fixed, the application will soft disable the add-in again.

    You can read more about this in the How to: Re-enable an Add-in That Has Been Disabled article.

    Wednesday, April 16, 2014 9:01 PM
  • hi I still haven't got this resolved. I checked the registry entries again. Please see the screenshot below:

    I've my .vsto file in C:\Program Files\MyCompany\MyCompany Outlook Email Signatures\MyCompany.Office.Outlook.AddIn.EmailSignatures.vsto

    The registry entry is in:  HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\OFFICE\OUTLOOK\ADDINS\MyCompany.Office.Outlook.AddIn.EmailSignatures

    Should it be somewhere else ?


    • Edited by hsam12 Tuesday, April 22, 2014 2:56 PM
    Tuesday, April 22, 2014 2:55 PM
  • Thank you. Your registry records look good.

    Is your add-in listed in the Diabled Items list when you start Outlook after installing the add-in?

    Did you have a chance to look at the Trust center settings?

    Tuesday, April 22, 2014 3:58 PM
  • looks like when I put the same registry entry under:

    HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\AddIns

    it seems to work. What is the difference between putting it under:

    HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\AddIns   vs

    HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\OFFICE\OUTLOOK\ADDINS

    Tuesday, April 22, 2014 7:02 PM
    • Marked as answer by hsam12 Monday, April 28, 2014 6:43 PM
    Tuesday, April 22, 2014 8:53 PM
  • Hi Hsam,

    Which version of Outlook are you using, wolud you mind share the set up file with us to reproduce the issue? Please remove the sensitive information and rebuild the setup file and then upload it to OneDrive.

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, April 23, 2014 9:12 AM
    Moderator
  • hi Eugene and Fei,

    I'm using Outlook 2013.

    It looks like when I stall the registry in HKEY_CURRENT_USER\Software\Microsoft\Office\Outlook\AddIns 

    it only works for the local administrator who installed the setup file. If I now login as another user(even if he is local administrator), the addin does not get added and registry entry is not there.

    I'm not sure what to do, we want it work as initial install by a local admin and then it should work for all the users(even if they're not local admin).

    I think the option you would suggest is install the registry key in:

    HKEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\OFFICE\OUTLOOK\ADDINS

    But that does not seem to do the addin automatically, I've go and invoke the .vsto file.

    Wednesday, April 23, 2014 8:54 PM
  • Follow the information Eugene supplied at http://blogs.msdn.com/b/vsto/archive/2010/03/08/deploying-your-vsto-add-ins-to-all-users-saurabh-bhatia.aspx.

    You cannot use ClickOnce, you must use an MSI installer for the addin, and it must be installed for All Users (HKLM) for what you want to work. If it's installed in the admin's registry profile it won't work for anyone else.


    Ken Slovak MVP - Outlook

    Wednesday, April 23, 2014 9:05 PM
  • Thanks,

    Actually found out that our Office 2013 version is 32 bit on Windows 8.1 OS 64 bit.

    So the registry needed to be in:

    HKEY_LOCAL_MACHINE\SOFTWARE\ Wow6432Node\MICROSOFT\OFFICE\OUTLOOK\ADDINS

    and it started working.

    Monday, April 28, 2014 6:42 PM
  • For future reference (taken from the middle of http://msdn.microsoft.com/en-us/library/cc442767.aspx):

    The path that you configure in this section depends on whether you create a per-user installer or a per-computer installer.

    Per-user installer                  

    HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn                  

    Per-computer installers based on Office version                  

    Office version

    InstallShield Configuration Path

    32-bit

    HKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn                          

    64-bit

    HKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn                          

    Per-computer installers based on Windows version                  

    Windows version

    InstallShield Configuration Path

    32-bit

    HKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn                          

    64-bit

    HKEY_LOCAL_MACHINE\SOFTWARE(32-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn                          

    HKEY_LOCAL_MACHINE\SOFTWARE(64-Bit)\Microsoft\Office\Excel\Addins\SampleCompany.ExcelAddIn                          

    Note                           Note                        

    An installer for 64-bit Windows requires two registry paths because it’s possible for users to run 32-bit and 64-bit versions of Office on a computer that runs 64-bit Windows.

    Note                                                   


    Michael Zlatkovsky | Program Manager, Visual Studio Tools for Office & Apps for Office

    Monday, April 28, 2014 7:19 PM
    Moderator