locked
Unable to launch Visual Studio's localhost web server RRS feed

  • Question

  • Hi,

     

    I just recently installed VS 2005 and when I try to run the default web service (hello world), It gives me the error:

     

    Unable to launch Visual Studio's localhost web server

     

    After doing some research, I found a couple references to changing the mode to 64-bit and back to 32-bit in order to reset the registry settings.  An example script is

     

    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 0
    %windir%\microsoft.net\framework64\v2.0.50727\aspnet_regiis.exe – i
    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1
    %windir%\microsoft.net\framework\v2.0.50727\aspnet_regiis.exe – i

    Unfortunately, running this in CMD prompt results in:

     

    The path requested could not be found.
    ErrNumber: -2147024893 (0x80070003)
    Error Trying To Get the Object: W3SVC/AppPools

     

    I'm stuck!  I've tried uninstalling both IIS and repairing VS 2005 to no avail.  Anybody know what to do?

     

    Thanks,

    Sean

    Saturday, May 26, 2007 2:42 AM

Answers

All replies

  •  

    try this forum http://forums.asp.net/17.aspx, it could be helpful

     

    thanks

    Monday, May 28, 2007 2:31 PM
  • Thanks for the link my friend.  I had to rummage through quite a few entries there from many well-intended people, but the solution finally was to completely uninstall Visual Studio, and both .NET framework 3 and 2, and then (making sure you already have IIS installed), re-install these (2.0, then 3.0, then Visual Studio).  So much pain, but it worked.

    Wednesday, May 30, 2007 4:36 AM
  • I was just about to reload everything.  When I launched the add/remove for VS.NET I checked out the "add/remove features" option and noticed I didn't have the "visual web developer" option checked.  (I'm mostly a fat/thick client guy)  So I checked that, hit next, popped my VS.NET install disk and VOILA, it worked!  Hopefully that saves someone some time!
    • Proposed as answer by Rizwan328 Wednesday, July 21, 2010 8:21 AM
    Tuesday, January 1, 2008 3:39 AM
  •  heydoug wrote:
    I was just about to reload everything.  When I launched the add/remove for VS.NET I checked out the "add/remove features" option and noticed I didn't have the "visual web developer" option checked.  (I'm mostly a fat/thick client guy)  So I checked that, hit next, popped my VS.NET install disk and VOILA, it worked!  Hopefully that saves someone some time!

     

    Yes, it saved me loads of time! You star.

     

    Mark.

    Saturday, February 9, 2008 11:25 AM
  • Hi, you are right that is the problem, when installing the VS originally the Visual Web Developer option was unchecked from the list where you choose the languages to install, it is the last option. I ran the add/remove program and checked the option, it worked.
    Thursday, June 5, 2008 4:09 AM
  • Godsend!
    Saturday, June 14, 2008 6:31 PM
  • I was just about to reload everything.  When I launched the add/remove for VS.NET I checked out the "add/remove features" option and noticed I didn't have the "visual web developer" option checked.  (I'm mostly a fat/thick client guy)  So I checked that, hit next, popped my VS.NET install disk and VOILA, it worked!  Hopefully that saves someone some time!
    Perfect! It helped me out......Thanks
    Wednesday, July 21, 2010 8:22 AM
  • You could have actually used to register asp.net to IIS using command aspnet_regiis -i from command prompt and restarted the machine. This could have rectified your problem.
    Regards, Nagendra
    Thursday, July 22, 2010 5:45 AM
  • Nagendra, maybe you didn't read the thread. It's about using the Visual Studio Development Server, not IIS.
    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects
    Friday, July 23, 2010 3:44 AM
    Moderator
  • tryed Nagendra option did not worked ...

     

    tryed below ..it worked ..

     

    I was just about to reload everything.  When I launched the add/remove for VS.NET I checked out the "add/remove features" option and noticed I didn't have the "visual web developer" option checked.  (I'm mostly a fat/thick client guy)  So I checked that, hit next, popped my VS.NET install disk and VOILA, it worked!  Hopefully that saves someone some time!

    Many Thanks

     


    Thursday, June 30, 2011 1:34 PM
  • Thanks a tonne. It worked!!..

     

     

    Monday, September 26, 2011 12:19 PM
  • This worked great for me.  Thanks.
    Friday, June 29, 2012 9:55 PM