none
developing .NET CF 3.5 for WinCE 6 RRS feed

  • Question

  • I keep getting this error whenever I try running a .NET Compact Framework 3.5 app on my WinCE 6.0 image:

    The version of the assembly System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089 cannot be loaded by this version of the Microsoft .NET Compact Framework.

    When I've created the app, I've clearly selected .NET Compact Framework 3.5, and the OS image also has the .NET Compact Framework 3.5 as a component.

    Please advise!

    Tuesday, November 15, 2011 11:40 AM

Answers

  • I've solved the problem by recreating and rebuilding the complete project (the class library project) and creating it as a .NET CF 3.5 project.
    • Marked as answer by Mang AlexMVP Tuesday, November 15, 2011 1:34 PM
    Tuesday, November 15, 2011 1:34 PM

All replies

  • I found that I get this error only when declaring a member of a type defined in a .dll I created.

    The .dll was not designed for Compact Framework 3.5. However, I had no such problems, either declaring nor using the entire class, when using VS2005 and .NET CF 2.0.

    Could you please help?

    Thanks very much in advance!

     

    Tuesday, November 15, 2011 1:23 PM
  • I've solved the problem by recreating and rebuilding the complete project (the class library project) and creating it as a .NET CF 3.5 project.
    • Marked as answer by Mang AlexMVP Tuesday, November 15, 2011 1:34 PM
    Tuesday, November 15, 2011 1:34 PM