locked
VT-x is disabled in the BIOS for both all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED) RRS feed

  • Question

  • User149770 posted

    Downloaded Xamarin Android Player and with >>next>> progress installed Virtual Box.

    when I try to start an amulator I got

    Faied to initialized device (name Of the emulator) VboxManager Commendt Failed

    and the detail of the error in Oracle Vm Virtualbox is

    VT-x is disabled in the BIOS for both all CPU modes (VERRVMXMSRALLVMX_DISABLED)

    How to fix it?

    Friday, October 23, 2015 2:15 PM

Answers

  • User163643 posted

    I solved this problem by disabnling PAE/NX in the VM Settings -System - Processor. Also made sure that the number of CPU was set to one. No changes in BIOS were needed for me.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, October 29, 2015 8:16 AM

All replies

  • User149770 posted

    On windows Before the pc opens -->F2--> Settings --> Configuration --> Intel Virtual Technology: [ENABLED] And my Xamarin Android Emulator works Hope it will be usefull if anyone needed ty.

    Wednesday, October 28, 2015 6:55 AM
  • User163643 posted

    I solved this problem by disabnling PAE/NX in the VM Settings -System - Processor. Also made sure that the number of CPU was set to one. No changes in BIOS were needed for me.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, October 29, 2015 8:16 AM
  • User149770 posted

    .

    Monday, February 8, 2016 10:36 AM
  • User149770 posted

    Here is the image of solution Settings > System Settings > Processor > Enable the PAE/NX option.

    Monday, February 8, 2016 10:47 AM
  • User176442 posted

    Thanks Samir ! It works for me.

    Friday, February 12, 2016 8:26 AM
  • User149770 posted

    @charly Glad it helped, I am happy for you

    Friday, February 12, 2016 8:46 AM
  • User149770 posted

    Afterwards I had some problems too like A week ago I had to format My laptop and then Andrid Player didnt worked again though I folowed what is above , then I found the solution. For whom still having troubles I recommend to steps of pumpingco.de/how-to-fix-xamarin-android-player-in-windows-10/ My Windows is 8.1 but still configurations are ok

    How to fix Xamarin Android Player in Windows 10 (Mine was 8.1 but still working) by Robin-Manuel Thiel If you have recently updated your PC to Windows 10 you might have noticed that our beloved Xamarin Android Player does not work anymore. Whenever we try to start it, the error message “Could not configure host-only network. Please reboot the computer and try again.” appears. This problem is caused by compatibility problems that VirtualBox 4 seems to have with Microsofts latest operation system. To fix this, we need to reinstall the Xamarin Android Player and configure the Virtual Box properly. Step 1 Uninstall the Xamarin Android Player and VirtualBox completely. Make sure that there is no XamarinAndPlayer directory under C:\Users{YOUR_USERNAME}\AppData\Roaming left. If there is one, delete it. Step 2 Download the Xamarin Android Player and install it. But do not start it yet! We need to do some other work first! Step 3 Download and install the latest version of VisualBox. It should be version 5 at least. This will update and clean the version that comes with Android Player at the moment to a version that is more compatible with Windows 10. Step 4 Now we need to configure the fresh installation of VirtualBox. For this, start it and go to the File/Preferences/Networking page and select the Virtual Host Only tab. Klick on the edit icon for the one existing network adapter and make sure the it is set in the following way: Adapter: IPv4 Address: 10.71.34.1 IPv4 Network Mask: 255.255.255.0

    DHCP Server: Enabled Server Address: 10.71.34.2 Server Mask: 255.255.255.0 Lower Address Bound: 10.71.34.101 Upper Address Bound: 10.71.34.199 Save your changes and close VirtualBox. Now we can launch the Xamarin Android Player and start installing the virtual machines available for download. It will find the correctly configured host only network adapter now. I really hope that helps everybody who is frustrated after updating his system to Windows 10.

    Huge thanks to Danny Pronk from the Xamarin Forums who found that solution.

    Friday, February 12, 2016 9:33 AM
  • User256068 posted

    I have done everything whatsoever written in the above lines, I m trying an installing HDP in my virtual Box, But everytime it is showing the same error

    VT-x is disabled in the BIOS for all CPU modes (VERRVMXMSRALLVMX_DISABLED).

    what can be done

    Sunday, September 11, 2016 8:40 AM
  • User296260 posted

    For this you have to do the setting at bios level.. 1. go to the BIOS after pressing F10 or as per your Laptop series/model. 2. Go to Configuration-> There find the Virtualization Technology in disbale mode, Just enable it. 3. Save & Exit 4. Restart the machine and go to VM and try now..

    It will work :)

    Thanks, Parveen

    Wednesday, February 1, 2017 5:33 AM