locked
BizTalk 2016 Server Administration - Instance of the WMI class is not found RRS feed

  • Question

  • I am brand new to BizTalk administration and trying to setup the certificate to use for AS2 communication, and running into some problems. The developer who built everything inside BizTalk did it under one account, domain\developer, but everything actually runs under domain\biztalk.

    All processing works great (meaning BizTalk can talk to the various databases on the local SQL Server), but when I am logged in as domain\biztalk and go to configure the AS2 certificate it seems like things get tripped up. According to this link (https://docs.microsoft.com/en-us/biztalk/core/configuring-certificates-for-as2), the certificate has to be in the Personal store of the user BizTalk runs under, so I've imported that. When I open up the Server Administration Console though, I expand BizTalk Server Administration, then expand BizTalk Group and receive this error:

    Failed to load group SERVERNAME\SQL2016:BizTalkMgmtDb data providers. Instance of the WMI class was not found.

    According to a couple of different links pointing to MSDN forums, it was suggested to restart the WMI service and it started working, but that didn't do it for me.

    Where it gets really strange is, since all development was done under domain\developer, I logged in as that account and expanding BizTalk Server Administration Console works - I can see all options (Applications, Parties and Platform Settings). When I go in to Parties and try to configure the certificate, I receive back a "No certificate available. No certificates meet the application criteria." error. I'm sure this is because I need to link the certificate to the domain\biztalk account, but since the SnapIn stuff doesn't load, I'm at a loss on how to proceed.

    Thanks for any help in advance!

    *Note: this is posted on ServerFault too, before I realized I had access to priority forums here because of MSDN. If I can get it working through this post, I'll update the one over there.

    Monday, June 18, 2018 12:50 PM

All replies

  • Let's clear up one thing first, the BizTalk Service Account should not be a BizTalk Administrator.

    So, after you add the certs as the Service Account, you need to log back in as yourself, presumably a BizTalk Administrator, to complete the configuration.

    Monday, June 18, 2018 4:55 PM
    Moderator
  • Got it! I can see where that makes sense. We are extremely new with BizTalk, so I suspect this is one of a few things we've done that probably aren't best practice. Luckily, it's a tight circle of who even has server access, so I'll cross the bridge of fixing this once we can get the AS2 certificate to show up. As it stands, we're only in dev too and getting this setup/configured has been less than simple, to say the least.

    Regarding the cert, it has been placed under the Computer, Service User And BizTalk Service BizTalk Group certificates stores for both Personal and Trusted Root CAs (six total locations).

    As a last resort test, I explicitly added the domain\BizTalk user account under the db_owner role for BizTalkMgmtDb and that got me closer! Now inside BizTalk Server Administration under the service account user, I don't run into the WMI error anymore - I can see Applications, Parties and Platform Settings. Unfortunately, when I go to properties under the specific Party and click Certificates, it still says no certificates found. Given that error, it must not be where it wants it to be so any suggestions here? As mentioned above, I've installed it in six places now (based on multiple blogs that said one or two of these) and no luck.

    Monday, June 18, 2018 6:37 PM
  • Be carefull not to mess things up
    Please take your time to read this document regarding domain users and -groups in a BTS environment
    https://docs.microsoft.com/en-us/biztalk/core/windows-groups-and-user-accounts-in-biztalk-server

    /Peter

    Monday, June 18, 2018 8:35 PM
  • Will do! Any ideas on the actual error we're getting though? I understand we need to be cautious of accounts, but we're still stuck on getting the AS2 certificate installed, so I'd prefer to get that issue resolved first and then move on to locking it down.
    Monday, June 18, 2018 9:47 PM