locked
IDE Not Debugging RRS feed

  • Question

  • User416713816 posted

    All,

    I have a web app that I have been developing in VS 2005.  Everything was fine until I had to re-load the operating system on my computer.  I re-installed VS 2005 and my project code and now when I set a breakpoint, the IDE is not recognizing it.  When I press F5, the code starts normally and my web page appears, but the IDE does not stop on the break point and my IDE is not in run mode.

    I verified all of my setting are specified as debug=true (webconfig, page directive, tools - options).  I also re-installed v2 ASP.NET framework.  but nothing seems to work.

    Any ideas?  The only thing I have different is that the VS2005 is an upgrade version and I did not install the VS2003 software.  VS2005 did not stop me and it installed properly.

    Thanks!  

    Eric Weller

    Sunday, December 27, 2009 12:13 PM

Answers

  • User416713816 posted

    All,

    I found out the problem is due to IE 8.0 and using VS 2003 or VS 2005.  These older debuggers have a problem attaching to the IE 8.0 session.  To overcome this issue, you need to disable the process growth feature of LCIE by follow the below steps:

    1)  Open RegEdit
    2)  Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3)  Add a dword under this key called TabProcGrowth
    4)  Set TabProcGrowth to 0

    I hope that this helps!  I have been working on this problem for 3 days now.

    Thanks!

    Eric Weller

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, December 29, 2009 11:05 PM
  • User416713816 posted

    All,

    After getting the debugger working again, I continued reloading software on my machine and somehow the debugger stopped working after loading some MS updates.  After struggling to get it working again, I finally gave up, reformatted the drive and reloaded XP again. 

    I found that the sequence the software is loaded is critical for preventing the error "Error while trying to run the project. Unable to start debugging on the webserver.You dont have permissions to debug webserver" from being issued.  You must load VS 2005 before installing IE 7 or 8.  Also, it is probably a good idea to load IE 7.0 first and update it and then load IE 8.0.  If the above hack does not work, the only way to get debugging back is to reload XP again and pay attention to the loading sequence.

    I hope that this info will keep someone from working days on getting debugging working.

    Thanks!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, January 1, 2010 7:57 PM

All replies

  • User236141260 posted

    Have you check your browser settings, it can also disable script debugging.

    open IE goto Tools-> Internet Options-> advance tab

    and inside browser uncheck Disable script debugging check box

    Sunday, December 27, 2009 5:30 PM
  • User416713816 posted

    Yes, I enabled script debugging, but I am pretty sure the problem is not on the browser but on the web server or its configuration. 

    Thanks!

    Sunday, December 27, 2009 5:44 PM
  • User-1853252149 posted

    I am pretty sure the problem is not on the browser but on the web server or its configuration. 

    Why do you think this?

    Jeff


    Tuesday, December 29, 2009 11:29 AM
  • User416713816 posted

    All,

    I found out the problem is due to IE 8.0 and using VS 2003 or VS 2005.  These older debuggers have a problem attaching to the IE 8.0 session.  To overcome this issue, you need to disable the process growth feature of LCIE by follow the below steps:

    1)  Open RegEdit
    2)  Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3)  Add a dword under this key called TabProcGrowth
    4)  Set TabProcGrowth to 0

    I hope that this helps!  I have been working on this problem for 3 days now.

    Thanks!

    Eric Weller

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, December 29, 2009 11:05 PM
  • User416713816 posted

    All,

    After getting the debugger working again, I continued reloading software on my machine and somehow the debugger stopped working after loading some MS updates.  After struggling to get it working again, I finally gave up, reformatted the drive and reloaded XP again. 

    I found that the sequence the software is loaded is critical for preventing the error "Error while trying to run the project. Unable to start debugging on the webserver.You dont have permissions to debug webserver" from being issued.  You must load VS 2005 before installing IE 7 or 8.  Also, it is probably a good idea to load IE 7.0 first and update it and then load IE 8.0.  If the above hack does not work, the only way to get debugging back is to reload XP again and pay attention to the loading sequence.

    I hope that this info will keep someone from working days on getting debugging working.

    Thanks!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, January 1, 2010 7:57 PM