locked
The report you requested requires further information RRS feed

  • Question

  • User-1227905837 posted

    how do i get the report to work correctly without giving this message and login prompt? 

    i searched the threads and i saw this a few times but i haven't actually seen a real solution

    ii have a reportviewer and a reportsource

    <CR:CrystalReportViewer ID="CrystalReportViewer1" runat="server" AutoDataBind="True"

    Height="50px" ReportSourceID="CrystalReportSource1" Width="350px" />

    <CR:CrystalReportSource ID="CrystalReportSource1" runat="server">

    <Report FileName="CrystalReport2.rpt">

    </Report>

    </CR:CrystalReportSource>

     and the crystalreport2.rpt i have it set to an ado.net dataset

    Friday, September 15, 2006 9:05 AM

All replies

  • User-1227905837 posted

    since nobody helped me on this i think i found a solution that worked for me

    i got rid of the crystalreportsource and clear out the reportsourceid

    instead laod the report in the codebehind like this
    Albums is the ADO.NET table i selected in the report wizard when i was created crystalreport2.rpt
     

     

    private ReportDocument customerReport; 

    private void ConfigureCrystalReports()
        {
            customerReport = new ReportDocument();
            string reportPath = Server.MapPath("CrystalReport2.rpt");
            customerReport.Load(reportPath);
            System.Data.SqlClient.SqlConnection conn = new System.Data.SqlClient.SqlConnection(ConfigurationManager.ConnectionStrings["Personal"].ConnectionString);
            System.Data.SqlClient.SqlDataAdapter adpt = new System.Data.SqlClient.SqlDataAdapter("SELECT * FROM Albums", conn);

            DataSet dataSet = new DataSet();
           
            adpt.Fill(dataSet, "Albums");
            customerReport.SetDataSource(dataSet);
            CrystalReportViewer1.ReportSource = customerReport;

        }

        private void Page_Init(object sender, EventArgs e)
        {
            ConfigureCrystalReports();
        }
     

    Saturday, September 16, 2006 11:18 AM
  • User11776262 posted

    I too was stumped by this. For no obvious reason the report wouldn't display in the report viewer. After a few hours of searching (googling) nothing came to mind that would solve the problem. One post suggested the report wasn't being loaded so I wrapped the code in a try-catch. The report was being loaded fine. This morning I tried something different. Instead of using the dataset as the datasource, I used a datatable. Below is the code I had that would render the message: "The report you requested requires further information".

            try
            {
                ReportDocument rpt = new ReportDocument();
                rpt.Load(Request.PhysicalApplicationPath + "RevenueReport.rpt");
                rpt.SetDataSource(dsUnitBase);
                CrystalReportViewer1.DisplayGroupTree = false;
                CrystalReportViewer1.ReportSource = rpt;
                CrystalReportViewer1.DataBind();
            }
            catch (Exception ex)
            {
                string strMessage = ex.Message;
                throw ex;
            }

     This piece of code works like a charm. The funny thing is, I have two Crystal Report jobs in this project so far. The first one uses a dataset and works just fine. I am using .Net 2.0 with Visual Studio 2005.

        try
            {
                DataTable dataTable = dsUnitBase.Tables[0];
                ReportDocument rpt = new ReportDocument();
                rpt.Load(Request.PhysicalApplicationPath + "RevenueReport.rpt");
                rpt.SetDataSource(dataTable);
                CrystalReportViewer1.DisplayGroupTree = false;
                CrystalReportViewer1.ReportSource = rpt;
                CrystalReportViewer1.DataBind();
            }
            catch (Exception ex)
            {
                string strMessage = ex.Message;
                throw ex;
            } 

    Tuesday, September 19, 2006 7:27 AM
  • User876569875 posted
    This solved my headache. God bless you and thanks for sharing your fix! [Yes]
    Wednesday, September 20, 2006 3:18 PM
  • User-13795406 posted

    Hi,

    Datatable its work.

    Wednesday, June 20, 2007 5:33 PM
  • User1939422607 posted

     Hi,

    I created a report in my project. while executing  the report i m getting a page with '' The report you requested requires further information" and  login details as database servername, username, password like that. I m using oracle as a database. And i used dataadapter for getting the data.
    And i used some dml statements for report, In oracle database these r executing in a correct manner. but in report i m getting repeated fields.

    Plz give the solution for this. I am the beginner for asp.net and crystalreports.

    thanx regards.


     

    Saturday, June 23, 2007 2:09 AM
  • User-13795406 posted

    Hi,

    You can use datatable instead of dataset.

     

    Best Regards

     

    Monday, June 25, 2007 2:50 AM
  • User1939422607 posted

    Hi, Thank u for u r advice.

    I added login id, login password in the report() function.

    as

     NewReportDocument.SetDatabaseLogon("loginid","password")

    Now i m not getting this problem.

    Thanks,Regards,

    hlp4al.

     

    Thursday, June 28, 2007 7:04 AM
  • User586997253 posted

    that works... u r a legend mate....

    Thursday, June 28, 2007 11:40 PM
  • User-1953148222 posted

    Hi Dear,

    It's working fine. Thanks a lot.

    Thursday, July 26, 2007 7:38 AM
  • User-199015008 posted

    I too, had the exact same problem.  In fact, I have scores of Crystal XI reports to which I pass a dataset and they run without problem.  Then, one report, amongst the many, failed with this message.  I took your advice and passed cr.datasource(dataset.tables(0)) and it worked perfectly.  Thank you for figuring this out.

    I am sure curious why this happened, but I'm sure happy to have a workaround.

    ...pjh

    Saturday, July 28, 2007 10:57 PM
  • User1467207536 posted

    Look at the following link:

    http://aspalliance.com/776

    Looks like Visual Studio 2005 and Crystal Reports XI don't work well togather.

    This solution works like a charm.

    Friday, December 7, 2007 4:45 PM
  • User1939422607 posted

    Hi..

    Login Prompt message comes when the Crystal ReportViewer EnableDatabaseLogonPrompt="True" .

    For not getting that Login Prompt Message add EnableDatabaseLogonPrompt="False" in aspx..

    u won't get once again this message.

    Try like this.. 

    Friday, February 22, 2008 6:28 AM
  • User-1713502297 posted

    Hi,

    I am facing the same problem.

    I have two different projects in both I am using crystal report with typed dataset. But its working fine in one project and in another it gives me same error. I cannot understand that is that a bug of crystal report or something else that we are missing.

    In fact in all forums site including business objects, peoples are suggesting to use datatable instead of typed dataset. But it is NOT a proper solution.And  in my case my requirement is something like that I can’t use datatable. If anyone found proper solution please inform me.

    Thanks, Pratik

    Saturday, April 12, 2008 8:42 AM
  • User11776262 posted

     You could spend hours or even days researching the problem or pay Microsoft or Business Objects to get a solution.

    Or, you could accept the fact that software isn't perfect and go with a known work-around and move on.

    I for one do not have time to waste on software inconsistancies. I must find a solution that works and move on.

    Besides, what could you be doing that won't work with referencing a data table instead?

    Saturday, April 12, 2008 3:40 PM
  • User823741452 posted

    You solution did`t help me, but i find another way :

     private void ConfigureCrystalReports()
        {

            customerReport = new ReportDocument();
            string reportPath = Server.MapPath("~/Rep/CrystalReport2.rpt");
            customerReport.Load(reportPath);
       
            TestDataSet dataSet = new TestDataSet();

            customerReport.SetDatabaseLogon("####", "####", "####", "####");
            customerReport.SetDataSource(dataSet);
            CrystalReportViewer1.ReportSource = customerReport;

        }

    Monday, June 16, 2008 10:23 AM
  • User1367574408 posted

    Thanks .. I am facing the same Problem "The report you requested requiresfurther information".

    But when i use DataTable as compare to DataSet It will work fine

    rd.Load(Server.MapPath(reportName))
    rd.SetDataSource(ds.table(0))
    CRV.HasCrystalLogo =
    False
    CRV.ReportSource = rd
    CRV.DataBind()
    CRV.ShowFirstPage()

    Wednesday, September 10, 2008 5:15 AM
  • User1367574408 posted

    Use DataTable as compare to dataset

    Wednesday, September 10, 2008 5:17 AM
  • User1856109674 posted

     that's quite good

    Wednesday, September 10, 2008 11:05 AM
  • User1356714375 posted

     In my app I have to extend the classified starter kit to act as a store front.

    None the less here it is. 

    Web.config connection string added.

     <connectionStrings>
            <add name="classifiedsConnection" connectionString="Data Source=SYSTEM1\SQLEXPRESS;Initial Catalog=TradeWinds;Integrated Security=True" providerName="System.Data.SqlClient"/>
        </connectionStrings>

     CrystalReport.rpt  in the root folder for testing.

    html

    <%@ Page Language="VB" AutoEventWireup="false" CodeFile="Default.aspx.vb" Inherits="_Default" %>
    <%@ Register TagPrefix="CR" Namespace="CrystalDecisions.Web" Assembly="CrystalDecisions.Web, Version=10.2.3600.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" %>

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

    <html xmlns="http://www.w3.org/1999/xhtml" >
    <head runat="server">
        <title>Untitled Page</title>
        <link href="/aspnet_client/System_Web/2_0_50727/CrystalReportWebFormViewer3/css/default.css"
            rel="stylesheet" type="text/css" />
    </head>
    <body>
        <form id="form1" runat="server">
        <div>
            &nbsp; &nbsp;
            <CR:CrystalReportViewer ID="CrystalReportViewer1" runat="server" AutoDataBind="true" />   
        </div>
        </form>
    </body>
    </html>

    code behind (probably over did it on the imports system.data.*   will check later)

    Imports System.Data
    Imports System.Data.Sql
    Imports System.Data.SqlClient
    Imports CrystalDecisions.CrystalReports.Engine
    Partial Class _Default
        Inherits System.Web.UI.Page

        Protected Sub Page_Load(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Load
            ConfigureCrystalReports()
        End Sub

        Private Sub ConfigureCrystalReports()
            Dim customerReport As New ReportDocument
            Dim reportPath As String = Server.MapPath("CrystalReport.rpt")
            customerReport.Load(reportPath)
            Dim conn As New System.Data.SqlClient.SqlConnection(ConfigurationManager.ConnectionStrings("classifiedsConnection").ConnectionString)
            Dim adpt As New System.Data.SqlClient.SqlDataAdapter("SELECT * FROM classifieds_TempOrder", conn)

            Dim dataSet As New DataSet()

            adpt.Fill(dataSet, "classifieds_TempOrder")
            customerReport.SetDataSource(dataSet)
            CrystalReportViewer1.ReportSource = customerReport

        End Sub

    End Class

     Many thanks to the original poster. It was killing me with the login prompts.

     

     


     

     

    Tuesday, November 18, 2008 7:39 PM
  • User1251306474 posted

    Thanx a lot. It worked well for me.

    Monday, May 25, 2009 5:35 AM
  • User561685558 posted

    I have found a solution that may well apply to everyone here.  The report I had created used an Integrated Security connection and I hadn't configured the website to utilise this.  To resolve, under IIS Admin I selected the properties for the website and went to Directory Security.  From there I turned off Anonymous Access and enabled Windows Integrated Authentication.  I then added the following tag to my web.config file:

            <identity impersonate="true" />

     This causes my Windows credentials to be passed to the report and it worked fine using the following VB code:

            Dim rep As CrystalReport1 = New CrystalReport1()
            Me.CrystalReportViewer1.ReportSource = rep
     

    Hope this helps someone.

    Wednesday, May 27, 2009 8:44 AM
  • User-906514870 posted

    One of the reason is that crystal report is not able to locate your database connection specifically when you built your report using Database Expert and move your application or changed your database name.

    How to check: Open your .rpt file and under Field Explorer right click Database Fields and click on "Verify Database". If it gives an error that means database connection is the problem.

    Fix: Create a database connection in your report file using Database Expert and all set.

     

    I had the same issue and get it fixed using above solution.

    Tuesday, August 11, 2009 8:43 PM
  • User-849555625 posted

    I'm beginner in ASP.Net and crystal report, using visual studio 2008 Express edition.

    . I got a problem in crystal report.

    Below the code for generating report.

    DataTable dt = new DataTable();

            DataSet ds = new DataSet();

            EmpSalaryTabTableAdapter ad = new EmpSalaryTabTableAdapter();

            string cmd = "SELECT EmpRegNo, Name, Basic, SalDate, TotWorkDays, WorkedDays, OverTime, Bonus FROM EmpSalaryTab WHERE (EmpRegNo = " + txtSearch.Text + ")";

            ds = DataBaseClass.SelectData(cmd);

            dt = ds.Tables[0];

            CrystalReportViewer1.Visible = true; 

            ReportDocument doc = new ReportDocument();

            doc.Load(Server.MapPath("EmpSalaryCr.rpt"));

            doc.SetDataSource(dt);

            CrystalReportViewer1.ReportSource = doc;

    This code is making the report, but whenever I'm giving to print or to export the report, I'm getting a message

    "The report you requested requires further information"

    DataSal

    Server

    name: <input value="DataSal" maxlength="255"> Database

    name: <input maxlength="255"> User

    name: <input maxlength="255">

    Password: <input maxlength="255">

    <input> Use Integrated Security 

    I'm using SQL 2005 express edition(included in VS 2008 pack).

    Please give a right solution for this.

    Thanks in advance.

    Tuesday, October 20, 2009 1:06 PM
  • User-1314454391 posted

    Thank u so much.It worked... 

    Wednesday, October 28, 2009 7:06 AM
  • User-1198891647 posted

    Try Adding this line to your code

    CrystalReportViewer1.EnableDatabaseLogonPrompt = false;

    Friday, November 20, 2009 11:09 AM
  • User-736993125 posted

    I my case i was using 

    myConnectionInfo.ServerName = <ODBC Connection name>
    myConnectionInfo.UserID = DBUser
    myConnectionInfo.Password = DBPwd

    When I looked at "Set Database Location..." in Crystal reports I noticed that my report was setup to use servername/database name and not ODBC connection. So I change my code thus to make it work.

    myConnectionInfo.ServerName = Servername
    myConnectionInfo.DatabaseName = DBname
    myConnectionInfo.UserID = DBUser
    myConnectionInfo.Password = DBPwd 

    Thursday, February 25, 2010 11:35 AM
  • User502905499 posted

    Thanks Xyligan 

    This was the only one solution that resolve my problem :)

    that's works very well....

    I think the best answer in this post.

    the code for VB is.

    Public Sub configuracrystalReports()
            Dim customerreport As New ReportDocument()
            Dim reportpath As String = Server.MapPath("~/CrystalReport.rpt")
            customerreport.Load(reportpath)
            Dim dataset As New Data.DataSet()
            customerreport.SetDatabaseLogon("USER", "PASS", "SERVER", "DB")
            customerreport.SetDataSource(dataset)
            CrystalReportViewer.ReportSource = customerreport
        End Sub

    i hope that it be helpful

    Thanks to God that guides me trougth good people likes you...

     

     

     

    Friday, March 12, 2010 9:52 AM
  • User-1198891647 posted

    Use a DataTable instead of DataSet

    DataSet dt= new DataSet();

     DataTable dataTable = dt.Tables["Table Name"];

    DataSet6 datatemp = new DataSet6();
                DataTable dataTable = datatemp.Tables["sp_ReportNew"];




    Friday, March 12, 2010 9:58 AM
  • User-584754365 posted

    Thank you, I tried that way and really worked!

     

    Regards

    David 

    Wednesday, April 7, 2010 2:11 PM
  • User-1268171501 posted

    If using Crystal 2008 SP3 the following worked for me as some of my reports had subreports, and those subreports didn't have any datasource associated with them.

    DataSetConverter.SetDataSource(currentReport, DataSet);

    if (currentReport.SubreportController.QuerySubreportNames().Count > 0)

    {   //Populate subreports   

       foreach (string subReportName in currentReport.SubreportController.QuerySubreportNames())  

            DataSetConverter.SetDataSource(currentReport, DataSet, subReportName);

    }

    Wednesday, July 7, 2010 1:41 PM
  • User2116614962 posted

    >Login Prompt message comes when the Crystal ReportViewer EnableDatabaseLogonPrompt="True" .

    this was useful to me.

    without the prompt i discovered that the problem was the with provider used in the report, not correctly installed on the server..


    Thanks 

    Wednesday, August 4, 2010 5:29 AM
  • User1204798508 posted

    hi,

    i am using XSD file for Crystalreport which uses Connection string from web.config file

    when i am going to print or export th report it will prompt that same msg "The report you requested requires further information"

    can anyone please help me

    thanks

    ashu

    Friday, September 24, 2010 2:21 AM
  • User1204798508 posted

    thanks

    i ve solved my problem

    Cool


    Friday, September 24, 2010 5:48 AM
  • User2113712437 posted

    I'm currently following a walkthrough tutorial that was made by Business Objects that explains how to use a custom class as a datasource for the report. After looking far a wide I cannot find a solution that works for me.

    The tutorial was using an ArrayList and I converted it to a DataTable hoping it would solve my issue but no luck.

    I don't understand what it is trying to log onto as I am not using a database but a just a static list of "Stock" objects as a datasource.

    Has anyone ran into this before?

    Thanks

    Friday, May 27, 2011 2:55 PM
  • User-1737630248 posted

    This works like a charm...i was getting the same issues...thaks a ton jbrunton..u saved my project..:)

    Wednesday, June 1, 2011 10:54 AM
  • User253389366 posted

    This worked for me....

    Hi, Thank u for u r advice.

    I added login id, login password in the report() function.

    as

     NewReportDocument.SetDatabaseLogon("loginid","password")

    FROM

    hlp4al.

    Tuesday, October 23, 2012 6:26 PM