none
BizTalk not processing inbound EDI with data 0.00 RRS feed

  • Question

  • Hi All,

    I am getting following error while processing inbound X12 810 file (4010) with segment data TXI|GS|0.00|0~

    Error encountered during parsing. The X12 transaction set with id '0001' contained in functional group with id '123', in interchange with id '123', with sender id 'xxx      ', receiver id 'abc      ' is being suspended with following errors:
    Error: 1 (Field level error)
    SegmentID: TXI
    Position in TS: 14
    Data Element ID: TXI02
    Position in Segment: 2
    Data Value: 0.00
    6: Invalid character in data element

    When I replace all '0.00' with '0' , this error disappears and I am able to process the file

    Normal validation and extended validation is switched off for that party in agreement.

    How can i make BizTalk 2013 R2 process this file without complaining on data 0.00 as it is?

    Thanks in advance

    Regards

    Vivek

    Wednesday, March 27, 2019 7:06 PM

Answers

  • This actually not a problem with BizTalk Server.

    The problem is your trading partner is sending slightly non-compliant EDI.

    TXI02 is a Real type and leading & trailing 0's are not allowed by X12 rules.  So, the problem is they are sending trailing 0's.

    In the THEM->YOU Agreement, you can set Allow leading and trailing zeros and spaces to bypass the rule.

    Thursday, March 28, 2019 7:14 PM

All replies

  • Hi All,

    I am getting following error while processing inbound X12 810 file (4010) with segment data TXI|GS|0.00|0~

    Error encountered during parsing. The X12 transaction set with id '0001' contained in functional group with id '123', in interchange with id '123', with sender id 'xxx      ', receiver id 'abc      ' is being suspended with following errors:
    Error: 1 (Field level error)
    SegmentID: TXI
    Position in TS: 14
    Data Element ID: TXI02
    Position in Segment: 2
    Data Value: 0.00
    6: Invalid character in data element

    When I replace all '0.00' with '0' , this error disappears and I am able to process the file

    Normal validation and extended validation is switched off for that party in agreement.

    How can i make BizTalk 2013 R2 process this file without complaining on data 0.00 as it is?

    Can we avoid pipeline to replace 0.00 with 0 and only use biztalk agreement settings to make this data processing possible?

    Thanks in advance

    Regards

    Vivek

    • Merged by Johns-305MVP Thursday, March 28, 2019 8:58 PM Duplicate
    Thursday, March 28, 2019 4:42 AM
  • Have you tried to change the datatype in the underlying schema base?
    Thursday, March 28, 2019 10:21 AM
  • You need to enable Allow leading and trailing zeroes and spaces in the agreement.

    Morten la Cour

    Thursday, March 28, 2019 12:41 PM
  • This actually not a problem with BizTalk Server.

    The problem is your trading partner is sending slightly non-compliant EDI.

    TXI02 is a Real type and leading & trailing 0's are not allowed by X12 rules.  So, the problem is they are sending trailing 0's.

    In the THEM->YOU Agreement, you can set Allow leading and trailing zeros and spaces to bypass the rule.

    Thursday, March 28, 2019 7:14 PM
  • Thanks you so much John, that makes sense to me now
    Friday, March 29, 2019 1:27 PM