none
Dialogs in Visual Studio 2015 Community have no boarders

    Question

  • Hi,

      I have brought a Visual Studio 2010 Pro application up to Visual Studio 2015 Community and all the boarders on ALL of my dialogs are not displaying. I found that this is an issue or correction of an issue in VS2015 but I have not found how to return the boarders to my dialogs. The dialogs were first created in VS2005 and looked good in VS2010. What property do I change and how do I change it to get boarders back in my dialog?

    Here is the code that makes the dialog appear on the screen:

        case WM_INITDIALOG:
            GetClientRect(hWnd, &DisplayRect);
            MoveWindow(hWnd, (ScreenWidth / 2 - DisplayRect.right / 2) + 10,
                (ScreenHeight / 2 - DisplayRect.bottom / 2 )+ 20,
                DisplayRect.right + 10, DisplayRect.bottom + 20, 1);

            Icon = LoadIcon (hInst, MAKEINTRESOURCE(IDI_OK));
            SendDlgItemMessage (hWnd, IDOK, BM_SETIMAGE, IMAGE_ICON, (LPARAM)Icon);
            DestroyIcon (Icon);
            Icon = LoadIcon (hInst, MAKEINTRESOURCE(IDI_CANCEL));
            SendDlgItemMessage (hWnd, IDCANCEL, BM_SETIMAGE, IMAGE_ICON, (LPARAM)Icon);
            DestroyIcon (Icon);

            BringWindowToTop( hWnd );
            UserNameHwnd = GetDlgItem( hWnd, IDC_LOGIN );
            SetFocus( UserNameHwnd );
            return (1);

    Any suggestions? This is killing all of my dialogs.


    Staff Embedded Firmware Engineer - CSI

    • Moved by Dave PatrickMVP Tuesday, October 25, 2016 6:26 PM
    • Moved by Naomi N Tuesday, October 25, 2016 6:33 PM Better answer can be here
    Tuesday, October 25, 2016 6:00 PM

All replies