none
Split 837 file at claims level biztalk 2010 RRS feed

  • Question

  • I have deployed the 837p muti schema, no singlr schema. The receive location used edi recive pipe line. Send port xml receive pipeline. I didn't change anything on the schema used default one.

    I have created the parties and agreement. 

    I want to debatch the incoming 837 at the claim lable. How ever when I drop the 837 file to input folder i get x12 interchange error 

    Error encountered during parsing. The X12 interchange with id '000045398', with sender id '521854809      ', receiver id '061057387      ' had the following errors:

    Error: 1 (Miscellaneous error)
     16: Invalid Control Standard Identifier

    Error: 2 (Field level error)
     SegmentID: ISA
     Position in TS: 1
     Data Element ID: ISA11
     Position in Segment: 11
     Data Value: ^
     7: Invalid code value


    • Edited by BuildSystem Friday, December 5, 2014 6:00 PM
    Friday, December 5, 2014 5:59 PM

Answers

  • That error has nothing to do with debatching the claim or the schema used.  The problem, as clearly stated, is with ISA11.

    On the Them->You tab of the Agreement, in the Envelopes section, set ISA11 Usage to Repetition Separator = ^.

    Saturday, December 6, 2014 1:32 AM
  • Changed the property of UseIsa11AsRepetitionSeprator value to TRUE, in EDI disassembler stage in the pipeline component and it should  work.

    Thanks

    Abhishek

    Saturday, December 6, 2014 4:15 AM

All replies

  • That error has nothing to do with debatching the claim or the schema used.  The problem, as clearly stated, is with ISA11.

    On the Them->You tab of the Agreement, in the Envelopes section, set ISA11 Usage to Repetition Separator = ^.

    Saturday, December 6, 2014 1:32 AM
  • Changed the property of UseIsa11AsRepetitionSeprator value to TRUE, in EDI disassembler stage in the pipeline component and it should  work.

    Thanks

    Abhishek

    Saturday, December 6, 2014 4:15 AM
  • I copied thr party from another environment it doesn't throw that error anymore. May be I was missing to set repetition separator while creating the party mannually.

    However it doesn't split 837 input file, it produce one xml file with all the claims. I want single claim in indivisual files. 

    Monday, December 8, 2014 7:21 PM
  • Please make sure that, in the party configuration under the 'Inbound batch processing Option" -Split interchange as Transaction Sets-Suspend Transaction Sets on Error is selected.

    Valid transactions will route as normal and invalid ones will be routed based on the failed message routing(for this Enable routing for failed messages at the Receive port).

    To know more details about Spilitting a batched EDI interchange, have a look at the below MSDN link

    http://msdn.microsoft.com/en-us/library/bb246013(v=bts.10).aspx

    http://stackoverflow.com/questions/8827380/debatching-837-files-with-multiple-claim

    Thanks

    Abhishek

    Monday, December 8, 2014 9:07 PM
  • I figured it out. There was a single 837 schema in another application. So Biztalk was not actually using the multi schema. As soon as I removed   that application it throw the 837 name space error, as soon as i change the namespace of the muti schema it worked. However thanks for resoving the ISA issue. 
    Monday, December 8, 2014 9:17 PM