locked
Cannot debug Asp.Net in VS 2005 + Windows XP and IE 8 RRS feed

  • Question

  • User924955874 posted

     Hi

    I am stuck with a scenario here where I am not able debug the asp.net web sites in Visual Studio 2005. When I am pressing F5 or selecting Start With Debugging option ,  internet explorer (IE 8) gets loaded and hosts the web site. But the debugger will get disconnected. i.e. It is working similar to  'Start without debugging' mode. Any breakpoints set inside code is also not hit.

     

    It was working well previously. I haven't made any changes in the settings. The only change which I recall is installling IE 8.0 .Previously it was IE 7.0.

    Point I Noticed: When I changed the default browser in Visual Studio 2005 to Firefox , the debugging is working fine.

     

    I could not find the reason. I am glad to accept suggestions and help.

     

     

    Tuesday, May 5, 2009 6:17 AM

Answers

  • User1837974337 posted

    i have faced this problem with IE8 Beta 2, searched for the fix had couple of them, lemme list out,

    Procedure 1

    1. Open RegEdit
    2.  Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3.  Add a dword under this key called TabProcGrowth
    4.  Set TabProcGrowth to 0

     Additional to it you need to do this

    1. Open Internet Explorer
    2. Go to Tools->Internet Options
    3. Switch to the Advanced tab
    4. Uncheck 'Disable script debugging (internet explorer)'

     i've got the fix from here, reasons for it are explained here, http://blogs.msdn.com/greggm/archive/2009/04/01/script-debugging-broken-in-vs-2005-after-installing-ie8.aspx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, May 5, 2009 6:42 AM

All replies

  • User1837974337 posted

    i have faced this problem with IE8 Beta 2, searched for the fix had couple of them, lemme list out,

    Procedure 1

    1. Open RegEdit
    2.  Browse to HKEY_LOCALMACHINE -> SOFTWARE -> Microsoft -> Internet Explorer -> Main
    3.  Add a dword under this key called TabProcGrowth
    4.  Set TabProcGrowth to 0

     Additional to it you need to do this

    1. Open Internet Explorer
    2. Go to Tools->Internet Options
    3. Switch to the Advanced tab
    4. Uncheck 'Disable script debugging (internet explorer)'

     i've got the fix from here, reasons for it are explained here, http://blogs.msdn.com/greggm/archive/2009/04/01/script-debugging-broken-in-vs-2005-after-installing-ie8.aspx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, May 5, 2009 6:42 AM
  • User924955874 posted

     Did it solve your issue? I will check the document and try. Thanks for reply

    Tuesday, May 5, 2009 7:10 AM
  • User924955874 posted

     Ya it worked... Thanks a lot...

    Tuesday, May 5, 2009 7:17 AM
  • User924955874 posted

     I did not change the second setting i.e unchecking Disable scrip debugging.  Without that it worked.

    I hope this setting wont create problems with IE.

    Tuesday, May 5, 2009 7:58 AM
  • User-2037441816 posted
    I´m having the same problem. I use VS 2005, C#, ansd after installing IE8 when I try to debug the IE launchs showing an erro: "Internet Explorer cannot display the webpage". The debug stays running. I´ve tryed the solution above, and also de Zones/1000/1207 solution, but it still doesn´t work. I´ve downgraded to IE7 -> error, Back to IE -> error! I really don´t know what else to do.
    Tuesday, May 26, 2009 12:36 PM