none
can not get printer to recognize .net framework 2.0 on windows ultimate 7, needed to run printer RRS feed

  • Question

  • I installed a Lexmark Z2300 printer and a pop-up states I need to install .NET Framework v2.0 from the micrrosoft website in order to complete the installation.  I tried to download the .NET Framework, but another pop-up tells me it is included in Windows Ultimate 7 already.  I tried to do it again, and it downloaded but said I need a different one for 64 bit (?), instead of 32 - which I have both.  I downloaded what it recommended for the 32, and the printer/computer is not recognizing it.  I still can't get the printer to work.

    Sunday, January 3, 2010 7:13 AM

Answers

  • Hi SweetPea3D,

    Thank you for your post.

    For Windows 7, it includes the .NET Framework 3.5.1 as an OS component. This means you will get the .NET Framework 2.0 SP2, 3.0 SP2 and 3.5 SP1 plus a few post 3.5 SP1 bug fixes. The feature of 3.0 SP2 and 3.5 SP1 can be added or removed via the Programs and Features control panel. Thus, we don't need to manually download .NET Framework 2.0 and install it on Windows 7. That's why your OS will not let you install it.

    For Lexmark Z2300 printer issue, you might refer to: http://support.lexmark.com/index?id=HO3518&locale=en&productCode=LEXMARK_Z2300&segment=DOWNLOAD&page=content&actp=HOTTIPS&userlocale=EN_US

    I notice the following points on the page:

    Upgrading to Windows 7?
    Disconnect USB and Uninstall Printer Driver First


    You should follow the steps mentioned in this link to have a try.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Friday, January 8, 2010 3:40 AM
    Tuesday, January 5, 2010 8:19 AM