none
U-Sql output to blob storage error

    Question

  • I'm using the following syntax to write the results of a U-SQL script to blob storage and I'm getting the error message below. 

    OUTPUT @dataset

    TO "wasb://<container>@<storage account>.blob.core.windows.net/20160314/defect_ml_dc_in.tsv"

    USING Outputters.Tsv();

    Error Message: A store failure has occured. This could be the result of a user operation or the store service is temporarily unavailable.


    • Edited by Cmbourgeois Monday, March 14, 2016 11:01 PM
    Monday, March 14, 2016 10:53 PM

Answers

  • I assume you actually provide a real container and storage account name?

    Furthermore, please make sure you have associated the storage account to the ADLA account as an additional data source (you can do it via the Portal for example).

    Also, I am not sure if the top-level name of a "directory" in blob storage can be just a number.

    Finally, can you please click on the error message to see the detailed error? If that error message is still confusing, please report back and I will file a request to fix the error message and make it easier to take action on.


    Michael Rys

    • Marked as answer by Cmbourgeois Tuesday, March 15, 2016 2:14 PM
    Tuesday, March 15, 2016 1:56 AM
    Moderator

All replies

  • I assume you actually provide a real container and storage account name?

    Furthermore, please make sure you have associated the storage account to the ADLA account as an additional data source (you can do it via the Portal for example).

    Also, I am not sure if the top-level name of a "directory" in blob storage can be just a number.

    Finally, can you please click on the error message to see the detailed error? If that error message is still confusing, please report back and I will file a request to fix the error message and make it easier to take action on.


    Michael Rys

    • Marked as answer by Cmbourgeois Tuesday, March 15, 2016 2:14 PM
    Tuesday, March 15, 2016 1:56 AM
    Moderator
  • Thank you, the issue was that the storage account was not associated to the ADLA account. The error message would not have pointed me in that direction, here are the details below.

    Here is the error message from VS 2015.

    Message: CsOpenStream failed with error 0x83090A02 (). Cosmos Path: wasb://...

    Description: A store failure has occured. This could be the result of a user operation or the store service is temporarily unavailable.

    Tuesday, March 15, 2016 2:13 PM