none
Outlook 2007 - updating add-in problem RRS feed

  • Question

  • Hey

    have found an issue whereby I have published the latest iteration of my add-in to the same location as the original (a local file server), using the iterate version number when publishing, running it in 2010 happily updates it, 2007 seems to think nothing has changed.

    Any suggestions? 60% of my team use 2007 and I'd rather not have to force them to uninstall

    Friday, February 8, 2013 10:58 AM

Answers

  • if you have deployed your addin setup via http then check with fidler, otherwise use process monitor to see if on machines where you do not get notified of update, vstor actually tries to check for new versions at all.

    Friday, February 8, 2013 2:04 PM

All replies

  • is the same vsto runtime used on machines with 2007 and 2010?
    Friday, February 8, 2013 11:53 AM
  • It kind of depends on the machine, really. I've made version 3.0 a pre-requisite on the add-in, but it's possible (likely even) that a 2010 user will already have the later version, just by nature of what we do. I can certainly confirm that I have both and didn't get the problem,  but someone else with both but the older version of Outlook did
    Friday, February 8, 2013 12:25 PM
  • if you have deployed your addin setup via http then check with fidler, otherwise use process monitor to see if on machines where you do not get notified of update, vstor actually tries to check for new versions at all.

    Friday, February 8, 2013 2:04 PM