none
When categorical fields included in logistic regression I get error "Exception of type 'Microsoft.Numerics.AFxLibraryException' was thrown. . ( Error 1000 )" RRS feed

  • Question

  • Hi,

    I'm trying to build a logistic regression model and every time I include a categorical variable as a potential predictor in the model I get the following error:

    "Exception of type 'Microsoft.Numerics.AFxLibraryException' was thrown. . Error 1000 "

    I tried building a decision tree instead and got the same error. I don't think it is to do with missing values as I passed in a categorical variable which had no missing values and got the same error.

    I've tried different categorical variables and it always gives the same error.

    The model runs fine if I limit the set of predictors to numeric.

    Does anyone know how to solve this?

                           Alistair.

    Monday, June 20, 2016 3:08 PM

Answers

  • Hi Alistair,

    Sorry for the trouble.  Could you please send us the dataset and a screenshot of the experiment to amlforum@microsoft.com?

    We could take a look to see what the issue is.  I have tried a dataset with a categorical feature and I was able to train and score on it.

    Thank you, Ilya

    Tuesday, June 21, 2016 4:41 AM