locked
Setting a default document with a custom extension RRS feed

  • Question

  • User1970795084 posted
    Hi, I've set up an HTTP Handler for the extension .aspa which works nicely. But my problem is I tried adding default.aspa to the default documents in IIS and it is not working - when I browse to just a folder I get the error "directory listing denied". Can anyone think of a round this?? I really want users to be able to browse to folders and be served the default.aspa page. eg. http://www.mysite.com/products would invoke my http handler and load: http://www.mysite.com/products/default.aspa Any suggestions welcome!!! cheers Rob
    Thursday, August 26, 2004 11:17 AM

All replies

  • User-1391363652 posted
    Did you make sure your web.config is configured to invoke your handler for aspa files and IIS is set up to pass requests for aspa files to the ASP.NET ISAPI? Also, remove anonymous and enable integrated Windows authentication on your web app. See if this fixes it.
    Thursday, August 26, 2004 12:07 PM