none
Email notifications not happening for some users RRS feed

  • Question

  • Hi,

    The email notifications are not getting sent to some users in SharePoint.

    Checks I performed till now -

    1. Email notifications are getting sent to all other users with no issues.
    2. Permissions for respective users on list - has read permissions
    3. Email ID of the user - valid email ID is present for the user in site collection

    Anything I am missing.


    Amol C kadam

    Monday, February 13, 2017 6:38 AM

All replies

  • Hi,

    Try to use telnet and follow the steps of below thread to checkthe connectivity between your users and the SMTP server.

    https://social.technet.microsoft.com/wiki/contents/articles/13771.troubleshooting-steps-for-sharepoint-alert-email-does-not-go-out.aspx

    Best Regards,

    Lee


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, February 14, 2017 2:51 AM
  • Hi Amol,

    You can check whether there are email records for that user on the Exchange Server.

    If it existed it means that the issue is not about the SharePoint. And make sure that the outlook for the user has no special settings(e.g. Junk E-mail setting).


    Cheers,
    Maruthu
    Please click the 'Mark as Answer' if this post solves your problem or "Vote As Helpful" if it was useful! :)
    Explore the SharePoint

    Tuesday, February 14, 2017 3:38 AM
  • Hi Maruthu,

    To check the email records on Exchange server, who could help me? (IT team as I am only a developer and don't have access to Exchange server)

    A reference link on how to check email records on Exchange server would help me.

    Thanks.


    Amol C kadam

    Wednesday, February 15, 2017 4:59 AM
  • Hi Lee,

    Email configuration does works well for all other users and do receive email notifications from SharePoint.

    The issue is with only some users, and they are AD users in same organization.

    Best Regards,


    Amol C kadam

    Wednesday, February 15, 2017 5:03 AM
  • Hi Amol,

    It is not possible for all users to check the records on Exchange server/access to it. Only super admins can check the records.

    Since you are confirming that other users are receiving emails properly and the issue is specific to users and not with SharePoint email configuration.

    But can you check if there are any issues in those specific accounts in active directory as well?


    Cheers,
    Maruthu
    Please click the 'Mark as Answer' if this post solves your problem or "Vote As Helpful" if it was useful! :)
    Explore the SharePoint

    Wednesday, February 15, 2017 7:10 AM
  • Hi,

    I can see below error message from "BAD mail" directory.

    "Unable to deliver message to the following recipients, due to being unable to connect successfully to the destination mail server."

    The user used to get auto email notification previously, but since last week, he is facing the issue.

    Also, the specific user can receive email notification when it is sent from other accounts.

    Thanks,


    Amol C kadam

    Wednesday, February 15, 2017 7:43 AM
  • So, it is clear that due to email box issues, that specific user is not getting emails.Hence contact your Exchange Server Admin to fix the mailbox issue since there is an error message "Bad Mail directory" 

    Cheers,
    Maruthu
    Please click the 'Mark as Answer' if this post solves your problem or "Vote As Helpful" if it was useful! :)
    Explore the SharePoint


    Wednesday, February 15, 2017 9:54 AM
  • It is not email box issue as user is getting emails from other accounts.

    Is it issue from -

    1. Loss of connection?

    Or any other problem?


    Amol C kadam

    Wednesday, February 15, 2017 10:32 AM
  • Hi,

    Does the users could logon to site successfully?

    Is it possible to delete and re add one user in the site and check?

    Best Regards,

    Lee


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, February 21, 2017 8:27 AM