locked
[PHP][Web Apps] Empty PHP Web App not interpreting code RRS feed

  • Question

  • Hi all,

    I'm new to Azure, and am attempting the first few steps in migrating from Amazon EC2 for my various machines. I'm attempting to turn a lot of my Amazon EC2 virtual machines hosting websites into Azure Web Apps. I'm fairly familiar with Linux, at least enough to move around and make changes in PHP.

    I created a new Web App, using the 'Empty PHP Website' template available on the Marketplace. I created the Web App and it's running. I got into the FTP and uploaded some PHP test files. However, they're interpreted as plain text, as if PHP wasn't installed. However, calling phpinfo() works just fine, and gives me information about the configuration.

    Any ideas as to what I'm doing wrong?

    Best,

    Mike



    Tuesday, June 9, 2015 1:55 PM

Answers

  • I took a look, and right now, this site is stopped, so it can't receive any requests.

    David

    Tuesday, June 9, 2015 10:17 PM

All replies

  • Additionally, I attempted to link to the three guides that I've folllowed Create a PHP web app in Azure App Service by tfitzmac, Create a WordPress web app in Azure App Service by tfitzmac and the Deploying PHP on Azure Course video on CodeGeek Youtube. However, I was unable to link to these because my account is apparently not verified, but I'm unable to do so.
    Tuesday, June 9, 2015 2:04 PM
  • Could you share the name of a test web site that is in this state? Also, please share specific URLs that you are hitting and are not working.

    Note that you can use Kudu Console to view/upload/investigate files more easily than with FTP.

    thanks,
    David

    Tuesday, June 9, 2015 2:31 PM
  • Hey David,

    You can see the comparison's here:

    http://dystopia-game.azurewebsites.net/

    http://www.dystopia-game.com

    Tuesday, June 9, 2015 3:30 PM
  • I took a look, and right now, this site is stopped, so it can't receive any requests.

    David

    Tuesday, June 9, 2015 10:17 PM