none
Empty Data Type

    Question

  • Can someone point me in the right direction on how to resolve this error message. It is part of a calculated field where I am using the following DAX statement. The error occurs during the Deployment process.

    =

    IF([CMZZCCAM] = BLANK(), 0.00,[CMZZCCAM]/100)

    Failed to save modifications to the server. Error returned: 'The column 'F55005[CurrCommAmt]' cannot be of type Empty. The Empty data type can only be set on a column if the column is either a calculated column or is part of a calculated table.

    '.

    Tuesday, February 28, 2017 6:40 PM

Answers

  • I was able to resolve this issue by deleting the two columns that  had errors and then creating two new calculated columns with the same exact formula as before and now they no longer error out.  Thanks for your help.

    Paul

    • Marked as answer by pbernick Wednesday, March 1, 2017 4:55 PM
    Wednesday, March 1, 2017 4:55 PM
  • Same problem, same solution.  I needed a custom date format that generated "Errors".  I added the IFERROR to trap the blanks.  Not sure if it is needed.  Deleting and recreating fixed the problem.

    Thanks, Paul


    Mario

    • Marked as answer by pbernick Tuesday, January 16, 2018 7:48 PM
    Tuesday, January 16, 2018 6:58 PM

All replies

  • Hi friend,

    Welcome to MSDN forum.

    What kind of project are you developing?

    As this forum is for Visual Studio IDE, I will try to help you target right forum for you to get a professional answer.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 1, 2017 3:54 AM
  • Hi Fletch I would appreciate any guidance you can provide.  The project I am working on is building Tabular Models inside of Visual Studio to support a Dashboard program called Panorama Necto.

    Paul

    Wednesday, March 1, 2017 1:45 PM
  • I was able to resolve this issue by deleting the two columns that  had errors and then creating two new calculated columns with the same exact formula as before and now they no longer error out.  Thanks for your help.

    Paul

    • Marked as answer by pbernick Wednesday, March 1, 2017 4:55 PM
    Wednesday, March 1, 2017 4:55 PM
  • Hi Paul,

    I'm glad that your issue has been resolved, and thanks for sharing the answer.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 2, 2017 1:25 AM
  • Same problem, same solution.  I needed a custom date format that generated "Errors".  I added the IFERROR to trap the blanks.  Not sure if it is needed.  Deleting and recreating fixed the problem.

    Thanks, Paul


    Mario

    • Marked as answer by pbernick Tuesday, January 16, 2018 7:48 PM
    Tuesday, January 16, 2018 6:58 PM
  • In case anyone comes back to this down the road like I did, I didn't have any errors in my calculated column, but I was able to resolve the issue.

    To do so, I changed the column name and deployed the solution.  If the column name is "Address", just change it to Address2 and deploy.

    After deploying successfully, just change it back to the original column name (i.e. "Address") and it might work.  Worked for me anyways...

    • Proposed as answer by RSmithman Wednesday, February 7, 2018 2:54 PM
    Wednesday, February 7, 2018 2:54 PM
  • The other option also works for me:

    1. Change Database name in Deployment Property.

    Ex: XXX -> XXX2

    2. Deploy the solution.

    3. Rename Database/Cube name as original back.

     XXX2 -> XXX

    Hope it also helps.

    Thursday, May 17, 2018 12:27 PM