none
Enable .NET Framework 4.0 on Windows Server 2008 R2 as feature RRS feed

  • Question

  • How do I enable .NET Framework 4.0 on Windows Server 2008 R2 as a feature? i've already installed the full profile installer but whenever I wish to add 4.0 as a feature to a specific role, it does not show up. What I see is still .Net Framework 3.5.1. I am using Windows Server 2008 R2 SP1 Standard edition. Is there anything I should do for .NET Framework 4.0 to show up on features?
    Tuesday, October 28, 2014 2:10 PM

Answers

  • " i've already installed the full profile installer "

    Did you install .NET 4.0 client profile, or .NET 4.0 full?

    If you installed the client profile, you should install the full framework:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    If you already installed the full package, verify it with this:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 4.0 selected, then post the first 12 lines AND the last 12 lines of the tool log here.

    • Marked as answer by Anna Cc Thursday, November 6, 2014 8:17 AM
    Tuesday, October 28, 2014 9:54 PM
  • Hi marvinjay,

    I agree with pvdg42, you can use .NET Framework Setup Verification Tool to verify if .NET Framework 4.0 was installed fine in your PC. If there is anything wrong with it, you can use the .NET Framework Repair Tool to repair it or reinstall it. After .NET Framework 4.0 is installed ok in your machine, and it still can't show up when you wish to add a feature to a specific role, please tell us where do you want it to appear? From your title "Enable .NET Framework 4.0 on Windows Server 2008 R2 as feature", I think you want it to show up in the control panel, the windows features dialog. As far as I know, if the .NET Framework isn't built in the OS, we can't find it in the windows features dialog. And it will be auto enabled after we install it. We don't need to enable it manually. 

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Anna Cc Thursday, November 6, 2014 8:17 AM
    Tuesday, November 4, 2014 9:56 AM

All replies

  • " i've already installed the full profile installer "

    Did you install .NET 4.0 client profile, or .NET 4.0 full?

    If you installed the client profile, you should install the full framework:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    If you already installed the full package, verify it with this:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 4.0 selected, then post the first 12 lines AND the last 12 lines of the tool log here.

    • Marked as answer by Anna Cc Thursday, November 6, 2014 8:17 AM
    Tuesday, October 28, 2014 9:54 PM
  • Hi marvinjay,

    I agree with pvdg42, you can use .NET Framework Setup Verification Tool to verify if .NET Framework 4.0 was installed fine in your PC. If there is anything wrong with it, you can use the .NET Framework Repair Tool to repair it or reinstall it. After .NET Framework 4.0 is installed ok in your machine, and it still can't show up when you wish to add a feature to a specific role, please tell us where do you want it to appear? From your title "Enable .NET Framework 4.0 on Windows Server 2008 R2 as feature", I think you want it to show up in the control panel, the windows features dialog. As far as I know, if the .NET Framework isn't built in the OS, we can't find it in the windows features dialog. And it will be auto enabled after we install it. We don't need to enable it manually. 

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Marked as answer by Anna Cc Thursday, November 6, 2014 8:17 AM
    Tuesday, November 4, 2014 9:56 AM