none
Could not contact the SSO server.Check that SSO is configured and that the SSO service is running on that server. (RPC: 0x800706BA: The RPC server is unavailable.) (SSO) RRS feed

  • Question

  • Hi,

    We have two BizTalk Server A , B and one database server C.

    On server A , biztalk is running fine with database configuration with database server C.

    I have installed biztalk on server B, but when I tried to configure BizTalk with Database server C then got the below issue:

    Please advice something !


    Thanks

    Tuesday, July 11, 2017 11:17 AM

All replies

  • Did you join existing SSO and Group?

    How to Add a Server to a Group
    https://msdn.microsoft.com/en-us/library/aa560729.aspx

    hth /Peter

    Tuesday, July 11, 2017 11:35 AM
  • Yes I tried to join existing group, but got the issue mentioned in my question.


    Thanks


    • Edited by Shivay_ Tuesday, July 11, 2017 11:49 AM
    Tuesday, July 11, 2017 11:49 AM
  • Did you create Server B by cloning Server A ? If so then you would have created the problem with MSDTC on server B sharing the same CID as Server A. In this case you'd need to reinstall MSDTC and then try.

    Even otherwise check the MSDTC connectivity between servers B and C using DTC Ping and/or DTC Tester.

    Regards.

    Wednesday, July 12, 2017 4:53 AM
  • Hi Shankycheil,

    I did not clone server B by cloning server A.

    I have checked msdtc and it is working fine between both server.

    I ping from server A to server C, and got the correct response.

    Even in admin console I connect existing group and it is added successfully.

    Should I create a new SSODB ?


    Thanks

    Wednesday, July 12, 2017 9:31 AM
  • Not clear to me if you have joined existing SSO system

    Wednesday, July 12, 2017 9:39 AM
  • When I click on Apply Configuration, then got the issue.


    Thanks

    Wednesday, July 12, 2017 9:59 AM
  • Sorry a bit too quick

    /Peter


    Wednesday, July 12, 2017 10:12 AM
  • Hi

    Is the SSO Server up and running on ServerA?

    If yes, the next thing you need to check is DTC communication between ServerA and ServerB. A firewall rule could be blocking RPC ports - you can disable firewall on both ServerA and ServerB and do a test.

    To test DTC, you can refer-

    https://support.microsoft.com/en-au/help/918331/how-to-troubleshoot-connectivity-issues-in-ms-dtc-by-using-the-dtcping


    Thanks Arindam

    Wednesday, July 12, 2017 12:55 PM
    Moderator
  • You'd also need to check connectivity between the servers A and B. Since A was the first server, that would host the Enterprise SSO Master and since the complaint is about the non-availability of the RPC endpoint it would be about the ports/network connectivity between servers A & B.

    Refer to https://msdn.microsoft.com/en-us/library/ee270761(v=bts.10).aspx and run through the complete tests/steps.

    Regards.

    Thursday, July 13, 2017 4:49 AM
  • Hi Guys,

    I tried to connect BizTalk Group in admin console and it is connected successfully.

    It means BizTalkMgmtDB is able to connect. I am also able to restart/stop the host instance.Only problem is that I am not able to create host instance for Server B because SSODB is missing.

    Can we create a new SSO database and configure biztalk on Server B to Server A's DB (biztalkmgmtDB,biztalkmsgboxDB etc) ?

    Will this trick work ?

    when I create new SSODB through BizTalk Configuration then will it create new BizTalkMgmtDB, BizTalkMsgBoxDB etc in Server C, that's only the confusion I have.



    Thanks

    Tuesday, July 18, 2017 7:05 AM
  • All BiuzTalk servers in the same setup uses the same SSODB
    Did you check MSDTC connectivity?
    On which server is the SSO service running?

    /Peter

    Tuesday, July 18, 2017 9:46 AM
  • Hi Arindam/Shankycheil/Peter,

    SSO Server is up and running on serverA.

    No port is block and firewall is on for both server.

    Even I am able to add group in BizTalk admin console on server B.

    I also ping from Server A to server B and Server B to server A and both r giving correct response.

    And I think when they are pinging well then it means there is no problem with RPC and DTC.

    Please suggest something else.



    Thanks


    • Edited by Shivay_ Monday, July 24, 2017 6:42 AM
    Monday, July 24, 2017 5:46 AM
  • Hi All,

    I used DTCPing tool and got the below issue:

    07-24, 12:51:11.956-->Start DTC connection test
    Name Resolution:
    A-BIZ-A-01-->172.12.10.87-->a-biz-a-01.aa.com
    07-24, 12:51:11.988-->Start RPC test (A-BIZ-A-02-->A-BIZ-A-01)
    RPC test is successful
    Partner's CID:7F893FD9-96AF-461D-951E-842DEEE73F6C
    ++++++++++++RPC test completed+++++++++++++++
    ++++++++++++Start DTC Binding Test +++++++++++++
    Trying Bind to A-BIZ-A-01
    07-24, 12:51:12.066-->A-BIZ-A-02 Initiating DTC Binding Test....
    Test Guid:D53D2E9D-3D60-407D-8CFC-8AB3C5564309
    Binding call to A-BIZ-A-01 Failed
    In  GUID
    Out GUID
    Session Down

    any idea where the problem is?


    Thanks

    Monday, July 24, 2017 8:52 AM
  • Hi guys,

    I have two more query :

    If server A is able to ping to server C then can we say that server C will surely ping server A ?

    If server A and server B are virtual machine than will I able to use same SSODB for both server ?

    Please suggest something !


    Thanks

    Monday, July 24, 2017 9:27 AM
  • Please have a look at https://msdn.microsoft.com/en-in/library/aa561924.aspx to address MSDTC related issues.

    When you try and join the group, the SSO on B will try and connect/establish connectivity to the Primary SSO Server on A. Can you ping A from B ?

    Since you mention both servers as being virtual servers have yo fixed IP's on both or are you running on DHCP ? try fixing IP's, try disabling firewalls...

    Regards.

    Monday, July 24, 2017 10:27 AM