locked
Blocked upgrading Samsung Build PC to Release Preview (Update the certificate for Secure Boot) RRS feed

  • Question

  • I'm trying to upgrade a Samsung Build PC to Release Preview. It currently has Consumer Preview running just fine.

    Part way into setup (I've tried both the downloaded setup and setup from an ISO image created from the downloaded setup) I get to a "What needs your attention: screen with the message "Update the certificate for Secure Boot".

    When I click the "Update" button I get the following:
    Message box: "We ran into a problem while trying to take care fo this for you. Please refresh the list and try again."

    I click OK then the "Refresh" button but see nothing happening (no delay). Clicking the "Update" button just gives me the error message again and no where to go. I checked my network connectivity in case it is silently hitting the web.

    Has anyone else hit this and discovered a workaround? Do I need to tweak the BIOS per http://social.msdn.microsoft.com/Forums/en-US/samsungpcgeneral/thread/7ded71b8-35d7-4ae2-bae8-a8aaa0bce19f or will that get me in worse trouble. Boot from the DVD rather than running setup from Consumer Preview?

    TIA for any help and suggestions,

    Walter Wittel

    Friday, June 1, 2012 3:13 PM

Answers

All replies

    • Marked as answer by wittelw Saturday, June 2, 2012 7:05 AM
    Friday, June 1, 2012 5:55 PM
  • Yeah, had the same problem and upgrading the firmware (and I presume the certificate at the same time) removed the problem.
    Friday, June 1, 2012 7:51 PM
  • I attempted downloading the BIOS Update app for the 700T-A04US. It would run but it stated it could not download the update. I didn't realize that is a different platform ID from the //BUILD version of the 700T. Samsung created a special version of the 700T for //BUILD with additional components. The BIOS Update app would not download an update because it cannot find updates for platform WJ (the //BUILD special version). The firmware found at http://www.samsung.com/global/buildpc/index.html  (Download #3) worked to update the BIOS and Windows 8 Release Preview is happily finishing up it's install. Thanks for the information.

    If anyone is interested, here is a PDF detailing the hardware differences for the //BUILD version of the 700T.
    http://www.samsung.com/global/windowspreview/data/1_Using_the_Samsung_Series_7_Slate_Windows_8_Consumer_Preview.pdf

    Friday, June 1, 2012 10:08 PM
  • On the Samsung BUILD tablet, I ran into the same problem (update the certificate for secure boot) when upgrading from Consumer Preview to the RTM build. I downloaded the System BIOS 05WJ (http://www.samsung.com/global/buildpc/index.html) as suggested above, and ran it as Administrator, it seemed to run fine and said it was going to reboot. It shutdown and never came back up. After a while, I power-cycled it.

    Now, it doesn't boot, when i power on the tablet I don't see the Samsung logo and the display is blank. I tried both the power+vol (Up& Down) and power+windows (on the tablet)to see if I can get into the BIOS menu, no luck and I and can't get anything to show on the display.

    Any suggestions on what I can try next?

    Monday, August 27, 2012 2:43 AM