none
BizTalk Connection drops

    Question

  • I have an issue when calling a method in unix server directly from BizTalk(BizTalk to Unix using HTTP adapter) during a stress test using testing tool, and there are no connection dropouts when a service is created and calling the unix server from it(Biztalk to WCF Service to Unix), do anyone know what the issue is?
    Friday, August 11, 2017 7:13 PM

All replies

  • Please can you more detailed information? 
    eg by dropouts do you mean messages gets suspended? 
    I assume you to write no connections / connection dropouts?

    Version of Biztalk could also be helpful

    As you have issues please check your system by using Biztalk Health Monitor
    https://www.microsoft.com/en-us/download/details.aspx?id=43716

    Check MS pages for default settings on isolated hosts and IIS
    The default settings after install/configure is not correct
    https://msdn.microsoft.com/en-us/library/cc296765(v=bts.10).aspx

    /Peter

    Saturday, August 12, 2017 5:42 AM
  • Hi Narish,

    Thank you for posting on MSDN forum.

    First we would want to know, what you want to achieve and what is your scenario ?

    If you want to establish a communication between BizTalk Server and Unix Server, Then please have a look into below some useful articles, that might be helpful for you to achieve your goal,

    BizTalk communication with Linux and other nix platforms!

    How to support windows and UNIX flat file at BizTalk end?

    Thanks

    [Kamlesh Kumar]

    Sunday, August 13, 2017 7:36 AM
  • <g class="gr_ gr_7 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="7" id="7">Narish</g>,

    How do you find there is a connection drop <g class="gr_ gr_39 gr-alert gr_gramm gr_inline_cards gr_run_anim Style multiReplace" data-gr-id="39" id="39">out ?</g>

    Are these two instances on different data center/domain/network?

    Without Biztalk request network admin to do a packet capture. Network packet capture can clearly show where you are losing data. 

    I would recommend first you try that then try with BizTalk 


    Ram

    Monday, August 14, 2017 5:30 PM
  • Hi ,

    Your question is missing important points :

    1)Where is connection dropout ,is it IIS level for HTTP adapter or message are getting suspended in bizTalk

    2) Have you looked into IIS logs and event log for any exception message.

    3) Is there connection failure between biztalk application and DB server on stress load .

     


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply

    Tuesday, August 15, 2017 10:15 AM