none
Error when making makeimg WinCE?????????? RRS feed

  • Question

  • Hello Am getting this error when i run the wince6.0 with the visual studio 2005 . Before that it creates the image. but when i try to compile with that again its saying this .. i ve not changed anything. i dnt ve a clue to solve this. pls tell .

    Error    4    makeimg: FATAL ERROR: Command returned non-zero exit code 1 (dec).   

    Regards

    Vinoth.

     

    • Moved by Michael Koster Monday, July 12, 2010 11:35 AM Wrong Forum, moved to Windows Embedded Forums (From:Visual Studio Debugger)
    Friday, July 9, 2010 11:58 AM

All replies

  •  

    Hi,

    Thanks for your post, but you may post the question at .NET Compact Framework where you may get quicker and better support.


    Sincerely,
    Eric
    MSDN Subscriber Support in Forum
    If you have any feedback of our support, please contact msdnmg@microsoft.com.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, July 12, 2010 12:39 AM
  • Just see the MakeImg.out file in the OSDesign release directory. Or post the MakeImg.out file here. See the path should be like this. D:\WINCE600\OSDesigns\<your soultion>\<your soultion>\RelDir\<your BSP Name>_<processor Archi>_Release or debug
    Vinoth.R http://vinoth-vinothblog.blogspot.com http://www.e-consystems.com
    Monday, July 12, 2010 11:51 AM
  • To add to Vinoth's reply, that error message is the result of another error, not the error itself.  So if you look above it in the makeimg output you should be able to find the real error.  If there is no error above it, then knowing what is happening before that error message will also help.
    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com
    Monday, July 12, 2010 12:53 PM
    Moderator
  • Hello

    When i try to make a clone of the orginal bsp which i have when i compile the clone am getting these errors.

    I tried clean sysgen eventhough i did that same error occuring .Can any body solve the issue what i ve,

    DEFFILE: C:\WINCE600\public\Script\oak\lib\ARMV4I\retail\jscript.def
    DLLENTRY: _DllMainCRTStartup
    makefile.def: Including C:\WINCE600\public\common\oak\misc\Sources.default
    makefile.def: BUILDROOT is C:\WINCE600\public\Script\cesysgen
    makefile.def: Including C:\WINCE600\PUBLIC\SCRIPT\CESYSGEN\sources
    makefile.def: Including C:\WINCE600\public\common\oak\misc\Sources.CE
    Directory: C:\WINCE600\PUBLIC\SCRIPT\CESYSGEN
    TARGETNAME: jscript
    makefile.def: Including C:\WINCE600\public\common\oak\misc\sources.ReleaseType_OAK
    NMAKE : fatal error U1073: don't know how to make 'C:\WINCE600\OSDesigns\Ais_v2\Ais_v2\Wince600\Ais_v2_ARMV4I\cesysgen\oak\lib\ARMV4I\retail\atls.lib'
    Stop.
    NMAKE : fatal error U1077: 'C:\WINCE600\sdk\bin\i386\nmake.exe' : return code '0x2'
    Stop.

     

    regards

    Vinoth.

    Tuesday, July 13, 2010 5:17 AM
  • Have you created you OSDesign for your cloned BSP or are you using the existing OSDesign and just change the BSP alone to Cloned BSP?
    Vinoth.R http://vinoth-vinothblog.blogspot.com http://www.e-consystems.com
    Tuesday, July 13, 2010 6:51 AM
  • Hello Vinoth

     

    Ya i created a new os design and the bsp is the one which is cloned. i dont know why bec the main os design and its bsp are working and am getting the image to download. but the cloned one making the error even i tried the 2 clone from the main bsp.

    Wednesday, July 14, 2010 4:48 AM
  •  i think the problem is not in your cloned BSP. I am suspecting the issue in your new OSDesign.you are missing to select some dependency component related to the Jscript component. Better you use the old OSDesign with your new cloned BSP to check whether the issue is in OSDesign or new cloned BSP.

    To do that open the Old OSDesign project.

    • Go to the CatalogItem->thirdparty->BSP. you can see the list of BSP and only one is selected.
    • Check your new cloned BSP and it will show a X mark. 
    • Uncheck the selected old BSP. Then the new cloned BSP will be shown with Checked mark.
    • Give Sysgen again.

    If you are able to succeed the build, issue will be in your new OSDesign.

     


    Vinoth.R http://vinoth-vinothblog.blogspot.com http://www.e-consystems.com
    Wednesday, July 14, 2010 6:08 AM
  • Per the error message
    NMAKE : fatal error U1073: don't know how to make 'C:\WINCE600\OSDesigns\Ais_v2\Ais_v2\Wince600\Ais_v2_ARMV4I\cesysgen\oak\lib\ARMV4I\retail\atls.lib'
    It missed the ATL library during SYSGEN Script project, add SYSGEN_ATL in your build should resolve this issue. Also do you apply update to data QFEs? Perhaps there is an update already fixed this issue.

    Wednesday, July 14, 2010 7:28 AM
  • ya sure i ll check it and let you know.thanks for the help vinoth.

     

     

    Vinoth.

    Wednesday, July 14, 2010 10:20 AM