none
Can't Create image out of the official VM depot RRS feed

  • Question

  • From: Jerkovich @JerkovichMccray via Twitter

    @Azure I figured you have to create an instance of the image. Put it up-still no application endpoint listening. #morecomplexthanneedbe.  

    @AzureSupport It's really that simple: copied an image of a Drupal VM, created an instance of it - DNS would not be resolved (timeout). EOS

    @AzureSupport I took an image out of the official VM depot and deployed as described, still nada.

    Link to Tweet: https://twitter.com/JerkovichMccray/status/651745402547531776

    Friday, October 9, 2015 6:13 PM

All replies

  • In fact I created the image out of the Azure repository:

    http://www.mediafire.com/view/druxmfu54gaemmt/Bildschirmfoto_2015-10-09_um_19.07.21.png

    Then I spinned up an instance using the image:

    http://www.mediafire.com/view/bhg9m9moixvuv10/Bildschirmfoto%202015-10-09%20um%2019.06.05.png

    The DNS however would just time-out. I do not quite understand why somebody would create an image with Drupal etc pre-installed and then not set up the webserver to accept inbound connections. So either the image itself is flawed or there is something else wrong.

    Another question on that: How can I ssh into the machine?

    Saturday, October 10, 2015 8:10 AM
  • Hi,

    Did you get it to work? Were you able to ssh into the machine?

    In your screenshot I see VM was provisioning, hence DNS might have been timing out. Currently I can ping the VM/service on port 22 and 80. When you provisioned the VM - did you do certificate or password auth?

    You can also check/change ports open on "Endpoints" tab in VM view of the portal.

    HTH,
    Boris.


    Boris Baryshnikov, Azure Compute/Linux/OSS

    Monday, October 12, 2015 6:49 PM
  • If it helps in the future.

    Assuming you have Azure CLI installed and you are logged in and selected a subscription where you are going to provision (if you have multiple). Run in ASM mode.

    I run these commands:

    azure vm create foobar113 -o vmdepot-58951-1-2 -l "East US" myuser MyActualPasswordHere --ssh

    azure vm endpoint create foobar113 80 80

    azure vm endpoint create foobar113 443 443

    How did I get the original image command? Search for Azure VM depot, then search for Drupal on the site and then pick whatever version you need (I picked "Drupal 7.39-0 (Ubuntu 14.04)"). Then I clicked on deployment script and selected a region to deploy. Note that it gives you a single command to create endpoints but you will need to run them separately if you don't want to provide additional parameters.

    You are welcome to try the site at http://foobar113.cloudapp.net/ (I will take it down in 48 hours). I have not made any config changes on it (like setting up email, etc.) - so you are likely won't get too far.

    HTH,
    Boris.


    Boris Baryshnikov, Azure Compute/Linux/OSS

    Monday, October 12, 2015 7:10 PM