locked
I cannot install wpf tool kits RRS feed

  • Question

  • I have installed .net framework 3.5 sp1 and also update my vs2008 to sp1 as well.  However, I still cannot install wpf tool kits and it's keep throw the error message "wpf toolkit requires .net framework 3.5 sp1.".  I tried repair and uninstall / reinstall .net framework 3.5 and sp1 but still not working. Is there anyone can help me on this issue? Thanks!

    Wednesday, May 6, 2009 6:47 PM

Answers

All replies

  • Have you restarted your computer after installing the .net framework 3.5?
    Wednesday, May 6, 2009 6:56 PM
  • Yes, I have restart my computer couple times after install .net framework3.5 sp1.  If I uninstall .net framework 3.5 and install the wpf tool kits.  The error message will pop up immediately.  If I run the wpf tool kits program after the .net framework 3.5 sp1 has been installed, the License agreement will pop up and the error message "wpf toolkit requires .net framework 3.5 sp1." show up after I click "install" button.

    Thanks!
    Wednesday, May 6, 2009 8:02 PM
  • In Visual Studio go to Help -> About Microsoft Visual Studio.

    This should give you the version of Visual Studio and of the Framework. Are you seeing the correct versions?

    (It should say Visual Studio 2008 Version 9.x.xxxx.1 SP and .NET Framework Version 3.5 SP1)
    Wednesday, May 6, 2009 9:20 PM
  • My verion information is:

    Microsoft vistual studio 2008
    Version 9.00729.1 SP

    Microsoft.NET Framework
    Version 3.5 SP1

    I think both are correct.  I also checked the regedit and it's looks same as my coworker. My coworker can installed wpf tool kit successfully, but I cannot.  I just wonder if the installer check something else in register key, that my computer is mssing.

    Thank you for reply.


    Wednesday, May 6, 2009 9:27 PM
  • I am not sure why you're getting this error but have you tried to download the source from.


    Then compile the app and just reference the compiled dlls in your app?
    • Proposed as answer by DeviantSeev Wednesday, May 6, 2009 9:51 PM
    • Marked as answer by andy860 Wednesday, May 6, 2009 9:53 PM
    Wednesday, May 6, 2009 9:34 PM
  • Hi DeviantSeev,

    Yes, That's what I am doing for now, and it's looks working to me.    I just wonder why I cannot run the installer.

    Anyway,

    Thank for your help.

    Wednesday, May 6, 2009 9:50 PM
  • You're welcome, if you run into issues with the dll you should probably contact Microsoft to let them know they have a possible bug in the installer.
    Wednesday, May 6, 2009 10:03 PM