Works with Tool says it requires .NET Framework 3.5 when 4 is installed RRS feed

  • Question

  • I'm attempting to run the Works with Tool v3.5 (executable modified 5/12/2010) on Windows Server 2008 R2 and it's immediately coming up with this error: "To use this tool please install .NET Framework 3.5 and try again." I'm fully updated right now, so I'm running .NET Framework 4. It seems to work fine on an up-to-date Windows 7 installation. I redownloaded the Software Certification Toolkit and reinstalled it, and I've tried this on a couple installations with the same error. Anything obvious I'm missing here?

    Tuesday, September 14, 2010 5:20 PM

All replies

  • In case anyone else runs into this issue, here's an update. I wrote the logo program directly and received the solution. The Works with Tool is only compatible with .NET 3.5 SP1 (or 3.5.1), and the installed level needs to be set to that -- no older will work, and having .NET 4.0 installed doesn't include the necessary functionality.

    Windows 7 comes with 3.5 SP1 out of the box, but Windows 2008 R2 only comes with .NET 3.5. I needed to go to the Server Manager and add the ".NET Framework 3.5.1 Features", and then the tool loaded without problems.

    Wednesday, September 22, 2010 3:05 PM