locked
Redirect after submitting web based form RRS feed

  • Question

  • Hi,

    I've been searching for stable solution to redirect infopath form to SharePoint page after the submitting, i came across some solution recommended to add Source parameter to the URL (Ref. http://msdn.microsoft.com/en-us/library/ms772417.aspx

    This solution works if i clicked on customized link that holds the Source parameter. but what if i went to the Form Library i clicked on Add document from there? how will i insert the source parameter then?

    Thanks

    Tuesday, January 24, 2012 2:36 PM

Answers

  • Hi,

     You can add the same parameter in the settings of your library. For this to work you have to click on the name of your content type, then in the advance settings of your content type append on the textbox "Enter the url of an existing document template" the ?source parameter.

    The path behind the source parameter have to be in the site collection.

    For this to work you have to "Allow management of content types" in the advanced settings of your library.

    Regards

    Batiste

    • Marked as answer by Abdullah_b Wednesday, January 25, 2012 6:07 AM
    Tuesday, January 24, 2012 3:16 PM

All replies

  • Hi,

     You can add the same parameter in the settings of your library. For this to work you have to click on the name of your content type, then in the advance settings of your content type append on the textbox "Enter the url of an existing document template" the ?source parameter.

    The path behind the source parameter have to be in the site collection.

    For this to work you have to "Allow management of content types" in the advanced settings of your library.

    Regards

    Batiste

    • Marked as answer by Abdullah_b Wednesday, January 25, 2012 6:07 AM
    Tuesday, January 24, 2012 3:16 PM
  • Thanks Batiste,

    This really worked fine for the form, it works after submitting the form. but what i want it to work after i press built in "Close" button that comes on the ribbon?

     

    Thanks

    Wednesday, January 25, 2012 6:05 AM
  • Thanks Batiste,

    it work fine with me after i put the source but only for the new Form  but when click on submit or close button for the saved Forms in the library does not work.

    Regards

    Asem

     

    Wednesday, January 25, 2012 7:16 AM